Bug 199753 - stalled web access after upgrade to 2.6.17-1.2157_FC5
stalled web access after upgrade to 2.6.17-1.2157_FC5
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-07-21 15:09 EDT by Claus Olesen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-28 17:41:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Claus Olesen 2006-07-21 15:09:40 EDT
Description of problem:
the symptom is that web access using a browser stalls with browser saying 
waiting for reply from the web site to which access is attempted.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. upgrade to latest kernel 2.6.17-1.2157_FC5
2. try accessing Internet sites (using browser)
Actual results:
browser stalls without ever getting a reply from the Internet.

Expected results:
the Internet should reply allowing the browser to finish.

Additional info:
the problem vanishes if instead kernel 2.6.16-1.2133_FC5 is used.

also, when the problem is present then dmesg has this
b44.c:v1.00 (Apr 7, 2006)
eth0: Broadcom 4400 10/100BaseT Ethernet 00:02:e3:53:5d:b2
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.

when the problem is not present then dmesg has this
b44.c:v0.97 (Nov 30, 2005)
eth0: Broadcom 4400 10/100BaseT Ethernet 00:02:e3:53:5d:b2
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is on for TX and on for RX.

(strangely? google and sbc are immune to the problem).
Comment 1 John W. Linville 2006-07-26 10:06:20 EDT
Would you mind trying the fedora-netdev kernels in order to ensure that this
problem is still pending upstream?


Please give them a try and post the results here...thanks!
Comment 2 Claus Olesen 2006-07-26 11:30:42 EDT
I tried but got no update...

$ sudo yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/4]
fedora-netdev                                                        [2/4]
updates                                                              [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
No Packages marked for Update/Obsoletion
Comment 3 Danny Ciarniello 2006-07-27 11:47:33 EDT
I have also run into this problem but only with one site: http://www.csfm.com

To reproduce, do wget http://www.csfm.com:

wget http://www.csfm.com
--08:48:52--  http://www.csfm.com/
           => `index.html.1'
Resolving www.csfm.com...
Connecting to www.csfm.com||:80... connected.
HTTP request sent, awaiting response...

I have tried different versions of the 2.6.17 kernel on fc4 (i386) and fc5
(x86-64) and all exhibit this problem.

I have also tried 2.6.16 and 2.6.15 kernels on fc4 and 2.6.9 kernels on fc3 and
RHEL and all work.
Comment 4 Pinnacle Support 2006-08-01 09:00:03 EDT
I have noticed the same problem with a few of our servers. 2.6.16 kernels work
fine, 2.6.17-1.2157_FC5 just hangs when connecting using various protocols (have
had it fail when connecting with http, ftp, pop and smtp).  Network card being
used in this case is an Intel Pro100 (e100 driver). 
Comment 5 John W. Linville 2006-08-01 14:39:21 EDT
Re: comment 2 -- please try the update again, as I have published later 
FC5.netdev kernels...thanks!
Comment 6 Claus Olesen 2006-08-02 13:55:21 EDT
I tried again - and got a new kernel
uname -a
Linux saturn 2.6.17-1.2157.2.1_FC5.netdev.7 #1 Fri Jul 28 17:30:46 EDT 2006 
i686 i686 i386 GNU/Linux

However, the problem is still there - web pages hang.
b44.c:v1.01 (Jun 16, 2006)
eth0: Broadcom 4400 10/100BaseT Ethernet 00:02:e3:53:5d:b2
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
Comment 7 John W. Linville 2006-08-28 15:47:46 EDT
Can you attach the output of runnint 'sysreport' on the box in question?  
Comment 8 Claus Olesen 2006-08-28 17:16:09 EDT
The problem that I had has been resolved.

To reiterate, after upgrading from
most web sites did not respond to web page requests using a web browser.

One of our sys admins looked into the matter. He tells me that based on this 
he changed the configuration of the firewall (which runs BSD) that I'm behind 
to ensure that the pass rules match these criterions

1) all 'pass' rules that can match TCP have 'flags S/SA'
2) all 'pass' rules have 'keep state'

After that the problem vanished. Looks to me like the latest kernel changed 
something for which the firewall configuration had to be changed (or maybe 
should have been changed to a long time ago).

If you still want the 'sysreport' I will attach it. Or should I close this 
Comment 9 John W. Linville 2006-08-28 17:41:08 EDT
Claus, sysreport will not be necessary...thanks!

Note You need to log in before you can comment on or make changes to this bug.