Bug 199758 - Patch to disable block layer bouncing for most memory on 64bit systems
Patch to disable block layer bouncing for most memory on 64bit systems
Status: CLOSED DUPLICATE of bug 236051
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-21 15:37 EDT by Paul Raines
Modified: 2013-03-06 00:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 16:57:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Disable block layer bouncing for most memory on 64bit systems (2.06 KB, patch)
2006-07-21 15:37 EDT, Paul Raines
no flags Details | Diff

  None (edit)
Description Paul Raines 2006-07-21 15:37:26 EDT
Description of problem:

Constant "Out of Memory" errors on x86_64 boxes when doing rsyncs
(but even when not doing rsync)

Version-Release number of selected component (if applicable):

2.6.9-34.0.2.ELsmp

How reproducible:

On one of my x86_64, I can reproduce it within 2 hours after reboot by
doing an rsync from one of my ext3 volumes to another.  I have seen it
happen on some boxes where rsync is not involved so it is is not specifically
an rsync thing.

Steps to Reproduce:
1. Boot up box
2. Start rsync between two large 10's GB volumes
3. Wait for "oom-killer" message in log
  
Actual results:

oom-killer starts killing random processes

Expected results:

The kernel should not run out of memory

Additional info:

SUSE has a patch fix for this I found which I have attached and it has fixed
the problem for me.  It is a patch called:

Disable block layer bouncing for most memory on 64bit systems
Comment 1 Paul Raines 2006-07-21 15:37:27 EDT
Created attachment 132841 [details]
Disable block layer bouncing for most memory on 64bit systems
Comment 2 Paul Raines 2006-07-21 15:38:23 EDT
Jason Baron emailed me that a possible workaround is to do:

echo 100 > /proc/sys/vm/lower_zone_protection
Comment 3 Jason Baron 2006-07-24 11:28:52 EDT
did the workaround help?
Comment 4 Paul Raines 2006-07-24 12:29:32 EDT
I have not tried it.  I have the patched kernel running on all my
dual Opteron boxes that are the only ones that give the error.
Comment 5 RHEL Product and Program Management 2006-10-05 17:02:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Jay Turner 2006-10-17 11:33:14 EDT
QE ack for 4.5.
Comment 7 Jay Turner 2006-10-17 11:33:50 EDT
QE ack for 4.5.
Comment 9 Peter Martuccelli 2007-03-08 16:31:22 EST
Jason are we moving ahead with Andi's patch for R4.5?  Do we know this to be a
problem and can justify including the patch in R4.5 based on code inspection? 
If not we should close the bug report out as wontfix.
Comment 11 Jason Baron 2007-08-27 16:57:18 EDT

*** This bug has been marked as a duplicate of 236051 ***

Note You need to log in before you can comment on or make changes to this bug.