Bug 19976 - Serial Mouse not immediately initialized in X
Summary: Serial Mouse not immediately initialized in X
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-29 01:56 UTC by Scott Merrill
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 17:47:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Merrill 2000-10-29 01:56:29 UTC
Compaq Armada 7370DMT laptop with 96 megabytes of RAM.
Red Hat Linux 7.0, with all errata updates applied.
Using blackbox as window manager, and xdm for graphical logins.

I have disabled the laptop's built-in PS/2 pointing device in the CMOS 
setup.  I use an external serial mouse.  

At the xdm login screen the external serial mouse does not work.  If I 
unplug the external serial mouse, and plug it back in, the mouse functions 
properly.

Comment 1 Scott Merrill 2000-10-29 13:56:47 UTC
Same situation occurs in console with gpm:
upon successful loading of gpm, mouse is not recognized.  Unplug the serial 
mouse, plug it immediately back in, and the mouse is recognized.

Further, if the above process is performed prior to X loading, X will then 
recognize the mouse.

Additional notes: I am using a Microsoft serial scroll mouse.

Comment 2 Mike A. Harris 2001-03-17 21:17:25 UTC
Since this problem is occuring in gpm AND in XFree86, it almost certainly is
not a bug I am betting.  Most likely you have a misconfigured mouse in
both gpm and XFree86.

Run mouseconfig and try different drivers until you find one that works.
If this doesn't happen, try playing changing the mouse configuration
by hand by editing your XF86Config-4 file and tweaking the mouse driver
config line by hand.  To find out a complete list of mouse drivers,
view the XFree86 mouse manpage:

man -a mouse




Note You need to log in before you can comment on or make changes to this bug.