Bug 199770 - Nedit really slow and crash on file-save / file-open
Nedit really slow and crash on file-save / file-open
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nedit (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-21 16:45 EDT by A. Lok
Modified: 2013-07-02 19:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 07:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Nedit window with green borders (4.58 KB, image/png)
2006-08-10 15:24 EDT, A. Lok
no flags Details
Patch to fix random nedit crashes (582 bytes, patch)
2006-08-30 07:21 EDT, Jindrich Novy
no flags Details | Diff

  None (edit)
Description A. Lok 2006-07-21 16:45:08 EDT
Description of problem:

Nedit is really, really slow, and crashes on file>save / file>open. I think it
is caused by an updated openmotif version, since at install nedit worked flawless.

Version-Release number of selected component (if applicable):
nedit-5.5-8.fc6
openmotif-2.3.0-0.2.1

Steps to Reproduce:
1. start Nedit
2. Notice slow redrawing of the application
3. press ctrl-S or File > Save
4. Nedit closes
  
Actual results:
Nedit closes

Expected results:
Save-file dialog

Additional info:

information after the crash on the command-line:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  91 (X_QueryColors)
  Value in failed request:  0xffb3b3b3
  Serial number of failed request:  4532
  Current serial number in output stream:  4532
Comment 1 A. Lok 2006-08-10 15:24:33 EDT
Created attachment 133974 [details]
Nedit window with green borders
Comment 2 A. Lok 2006-08-10 15:28:36 EDT
Updated to Fedora Core 6 test 2, since it isn't working right in this version
either.

-Slow behaviour is gone
-Still crashes on File > Save, File > Open
-Nedit windows have a green border (see attached image)

installed versions:
nedit 5.5-8.fc6
libXp 1.0.0-4.1
openmotif 2.3.0-0.2.1
Comment 3 Jindrich Novy 2006-08-28 10:40:47 EDT
Yes, it's likely caused by the updated openmotif, nedit crashes with:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  91 (X_QueryColors)
  Value in failed request:  0xffb3b3b3
  Serial number of failed request:  4596
  Current serial number in output stream:  4596

on File/Open...
Comment 4 Thomas Woerner 2006-08-28 11:27:51 EDT
Jindrich: Is nedit setting the path for rgb.txt?
Comment 5 Jindrich Novy 2006-08-28 12:16:06 EDT
Nope, I grepped all nedit sources, but found no reference to rgb.txt.
Comment 6 Thomas Woerner 2006-08-29 11:25:34 EDT
This seems to be a xlib problem with the composite extension. For now you have
two solutions:

1) Set XLIB_SKIP_ARGB_VISUALS environment variable
   export XLIB_SKIP_ARGB_VISUALS=1

2) Set visual for nedit to Default
   nedit -xrm "*VisualID: Default"

--
Assigning back to nedit.
Comment 7 Jindrich Novy 2006-08-30 07:21:48 EDT
Created attachment 135197 [details]
Patch to fix random nedit crashes

I wrote this simple patch to fix this. It still allows an user to redefine the
default visual by the -xrm nedit option, but it disables best visual detection
and sets the Default one regardless the list of visuals which is available.

Note You need to log in before you can comment on or make changes to this bug.