Bug 1997720 - Kernel fix for ch341 to be ported/adopted by Fedora34
Summary: Kernel fix for ch341 to be ported/adopted by Fedora34
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-25 16:57 UTC by Peter Larsen
Modified: 2021-09-08 15:06 UTC (History)
18 users (show)

Fixed In Version: kernel-5.13.14-100.fc33 kernel-5.13.14-200.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1997735 (view as bug list)
Environment:
Last Closed: 2021-09-08 15:05:13 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 214131 0 None None None 2021-08-25 16:57:54 UTC

Internal Links: 1997735

Description Peter Larsen 2021-08-25 16:57:54 UTC
1. Please describe the problem:
A kernel bug was reported that impacts Fedora 34 when using serial communication over USB. This is meant as a tracker to ensure the git reversal impacts Fedora 34 and not just Rawhide.

2. What is the Version-Release number of the kernel:
5.10.* - see kernel.org BZ https://bugzilla.kernel.org/show_bug.cgi?id=214131

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Yes - this was a recent kernel change that is being reverted. 

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Use esptool.py (part of Arduino for instance) to communicate with a USB device using the serial protocol, and it fails. The kernel is not passing in responses from the client/unit.


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Unknown - but I would assume so since the BZ is confirmed on the kernel.

6. Are you running any modules that not shipped with directly Fedora's kernel?:

No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

See attached BZ.

Comment 1 Fedora Update System 2021-09-04 13:30:23 UTC
FEDORA-2021-6075bdc283 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-6075bdc283

Comment 2 Fedora Update System 2021-09-04 13:30:25 UTC
FEDORA-2021-f0afd37c8a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-f0afd37c8a

Comment 3 Fedora Update System 2021-09-04 20:28:03 UTC
FEDORA-2021-6075bdc283 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-6075bdc283`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-6075bdc283

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-09-04 20:39:07 UTC
FEDORA-2021-f0afd37c8a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-f0afd37c8a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-f0afd37c8a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-09-08 15:05:13 UTC
FEDORA-2021-6075bdc283 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2021-09-08 15:06:41 UTC
FEDORA-2021-f0afd37c8a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.