Bug 1997839 - Yelp 41 beta 1 can't load XML file by path (breaks anaconda)
Summary: Yelp 41 beta 1 can't load XML file by path (breaks anaconda)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yelp
Version: 35
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedFreezeException Accept...
Depends On:
Blocks: BetaFreezeException, F35BetaFreezeException F35FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2021-08-25 22:44 UTC by Adam Williamson
Modified: 2021-08-30 21:42 UTC (History)
14 users (show)

Fixed In Version: yelp-41~beta2-1.fc36 yelp-41~beta2-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-30 21:42:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2021-08-25 22:44:34 UTC
In today's Fedora 35 and Rawhide composes, all anaconda's help screens are broken - clicking any "Help" button in anaconda launches Yelp but shows an empty grey screen.

This seems to be because passing yelp the path to a local XML file (which is what anaconda does) doesn't work. If I run the same command anaconda runs from a console, I get the same blank grey screen, and some error messages:

[liveuser@localhost-live ~]$ yelp /usr/share/anaconda/help/en-US/WelcomeSpoke.xml

(yelp:3172): GLib-CRITICAL **: 18:39:31.059: g_uri_join_internal: assertion 'host != NULL || (path[0] != '/' || path[1] != '/')' failed

** (yelp:3172): CRITICAL **: 18:39:31.059: void webkit_web_view_load_uri(WebKitWebView*, const gchar*): assertion 'uri' failed

Proposing as a Final blocker as a violation of Final criterion "Any element in the installer interface(s) which is clearly intended to display 'help' text must do so correctly when activated" - https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria#installer-help . Also proposing as a Beta FE as this seems severe enough that it would be a good idea to fix it for Beta (and it can't be fixed with an update).

Comment 1 Shaun McCance 2021-08-26 20:42:21 UTC
Confirmed. Probably a regression from moving to GUri. Filed upstream bug: https://gitlab.gnome.org/GNOME/yelp/-/issues/182

Comment 2 Adam Williamson 2021-08-27 18:24:24 UTC
+4 for both Beta FE and Final blocker in https://pagure.io/fedora-qa/blocker-review/issue/410 , marking accepted in both cases.

Comment 3 Shaun McCance 2021-08-29 00:40:12 UTC
Fixed in master upstream. Do you need another beta to test Fedora?

Comment 4 Adam Williamson 2021-08-29 06:23:49 UTC
not necessarily, the fix could just be backported downstream. whichever is easiest, i guess. if no-one does anything by monday i'll backport it.

Comment 5 Shaun McCance 2021-08-30 00:46:43 UTC
I went ahead and rolled a 41.beta2. It's a pretty big regression, and it could be hitting other early testers who didn't tag me. Thanks for catching it.

Comment 6 David King 2021-08-30 07:56:42 UTC
Thanks Shaun!

Comment 7 Fedora Update System 2021-08-30 08:03:51 UTC
FEDORA-2021-637225513f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-637225513f

Comment 8 Fedora Update System 2021-08-30 19:01:23 UTC
FEDORA-2021-637225513f has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-637225513f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-637225513f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-08-30 21:42:18 UTC
FEDORA-2021-637225513f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.