Bug 199790 - mono-core conflicts with mono-core
mono-core conflicts with mono-core
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On: 185690
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-07-21 21:33 EDT by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 05:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2006-07-21 21:33:53 EDT
Description of problem:
Due to yums desire to install both i386 and x86_64 packages on a x86_64 system a
conflict arises when installing mono-core

Version-Release number of selected component (if applicable):
mono-core-1.1.16-1.1

How reproducible:
100%

Steps to Reproduce:
1. yum install mono-core
  
Actual results:
massive conflict output

Expected results:
Succesful install

Additional info:
AMD64 X2 4400+ running Development 22072006
Comment 1 Matthias Clasen 2006-07-25 11:58:11 EDT
Why does yum try to install mono-core-i386 on x86_64 ?
Comment 2 David Nielsen 2006-07-26 20:11:21 EDT
Jesse Keating explained to me that this is the default behavior on FC6, I find
it endlessly annoying as it causes problems left and right, takes up diskspace
and takes longer to download.. however this is a debate to take up with Seth
Vidal I guess.
Comment 3 Alexander Larsson 2006-07-27 17:08:22 EDT
I think this would be fixed by moving mono to %libdir. As per bug 185690.
Comment 4 Toshio Kuratomi 2006-07-27 17:26:03 EDT
Hmm.. How are we going to fix this in time for FC6?  I was anticipating the move
to libdir would be too big a change until FC7.
Comment 5 Alexander Larsson 2006-07-27 22:09:26 EDT
Yeah. I'm not sure. Does this conflict really happen in a default install on x86-64?
Comment 6 David Nielsen 2006-07-28 01:56:51 EDT
This is a bog standard install
Comment 7 Alexander Larsson 2006-07-28 16:17:40 EDT
Ugh, then we might have to move to libdir in fc6 anyway. I'll be gone next week,
but i'll take a look at this the week after that.
Comment 8 Alexander Larsson 2006-08-10 05:47:27 EDT
I think this should be fixed in mono-1.1.16.1-1. This version has libmono split
out into mono-lib, and the only devel package is mono-lib-devel. Both these
packages are multilib safe, and they should be the only 32bit ones pulled into
the 64bit distro. 

Note You need to log in before you can comment on or make changes to this bug.