Bug 19980 - kernel NULL pointer dereference
kernel NULL pointer dereference
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-29 02:11 EST by Bill Chatfield
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-29 02:25:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Chatfield 2000-10-29 02:11:55 EST
The console dump is:


Unable to handle kernel NULL pointer dereference at virtual address 
00000018
current->tss.cr3 = 06620000, %cr3 = 06620000
*pde = 00000000
Oops: 0002
CPU:    0
EIP:    0010:[<c010e00d>]
EFLAGS: 00010206
eax: 00000000   ebx:c7aba4e0   ecx:00000018   edx:bffff834
esi: bffff834   edi:c2245fc0   ebp:fffffff2   esp:c2245f98
ds: 0018   es: 0018   ss: 0018
Process mingetty (pid: 4089, process nr: 22, stackpage=c2245000)
Stack: 00000280 bffff854 00000000 c2244000 00000000 00001000 00000003 
00000022
       ffffffff 00000000 c0109f58 bffff81c 00000037 400157d8 00001000 
00000280
       bffff854 0000005a 0000002b 0000002b 0000005a 400121bd 00000023 
00000206
Call Trace: [<c0109f58>]
Code: ff 09 0f 88 9b 8f 0c 00 f6 44 24 24 20 75 2b bd f7 ff ff ff
INIT: Id "1" respawning too fast; disabled for 5 minutes


It kept spewing out a bunch of these messages.  They're all the same 
except for the pid of the process at the end.  I'd get a whole group of 
these messages with only one "INIT" message at the end, and then a few 
seconds later it would do it all over again.

This happend immediately after the daylight savings time change (EST).  I 
don't know if it was caused by that or not.

This is a stock RHL7 system, with no updates.  I was running RealPlayer 7.
Comment 1 Bill Chatfield 2000-10-29 02:25:56 EST
This was the first of the many similar messages which was logged in
/var/log/messages.


Oct 29 00:53:39 jhad kernel: Unable to handle kernel NULL pointer dereference at
virtual address 00000018
Oct 29 00:53:39 jhad kernel: current->tss.cr3 = 05936000, %cr3 = 05936000
Oct 29 00:53:39 jhad kernel: *pde = 00000000
Oct 29 00:53:39 jhad kernel: Oops: 0002
Oct 29 00:53:39 jhad kernel: CPU:    0
Oct 29 00:53:39 jhad kernel: EIP:    0010:[old_mmap+89/248]
Oct 29 00:53:39 jhad kernel: EFLAGS: 00210206
Oct 29 00:53:39 jhad kernel: eax: 00000000   ebx: c401b040   ecx: 00000018  
edx: bfffa628
Oct 29 00:53:39 jhad kernel: esi: bfffa628   edi: c5967fc0   ebp: fffffff2  
esp: c5967f98
Oct 29 00:53:39 jhad kernel: ds: 0018   es: 0018   ss: 0018
Oct 29 00:53:39 jhad kernel: Process magicdev (pid: 852, process nr: 38,
stackpage=c5967000)
Oct 29 00:53:39 jhad kernel: Stack: 08086860 bfffa6b8 00000000 c5966000 00000000
00001000 00000003 00000022
Oct 29 00:53:39 jhad kernel:        ffffffff 00000000 c0109f58 bfffa610 00000000
405ba53c 00001000 08086860
Oct 29 00:53:40 jhad kernel:        bfffa6b8 0000005a 0000002b 0000002b 0000005a
4057567d 00000023 00200206
Oct 29 00:53:40 jhad kernel: Call Trace: [system_call+52/56]
Oct 29 00:53:40 jhad kernel: Code: ff 09 0f 88 9b 8f 0c 00 f6 44 24 24 20 75 2b
bd f7 ff ff ff
Comment 2 Bill Chatfield 2000-11-05 00:46:04 EST
This problem appears to have been caused by bad hardware.  I've rebuilt my
machine with a new processor and motherboard and I do not have this problem
anymore.  Sorry.

Note You need to log in before you can comment on or make changes to this bug.