Bug 199804 - Checkboxes in browser chrome are very hard to see
Checkboxes in browser chrome are very hard to see
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-22 07:51 EDT by Jonathan Wakely
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 14:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image showing barely visible check (30.36 KB, image/png)
2006-07-22 07:51 EDT, Jonathan Wakely
no flags Details
another example of hard to see checks (14.80 KB, image/png)
2006-07-22 07:55 EDT, Jonathan Wakely
no flags Details
gtk widgets (3.99 KB, image/png)
2007-07-18 20:16 EDT, Jonathan Wakely
no flags Details

  None (edit)
Description Jonathan Wakely 2006-07-22 07:51:16 EDT
Description of problem:
Checkboxes in browser chrome are very hard to see.

Version-Release number of selected component (if applicable):
firefox-1.5.0.4-1.2.fc5
kdelibs-3.5.3-0.4.fc5
kdeartwork-3.5.3-0.1.fc5
(up to date FC5 system)

I think this only applies to GTK builds of firefox, but I'm not sure.

I've tried a few different colour schemes but checkboxes such as the "Use my
choice for all cookies from this site" one on the cookie dialog are checked in a
very light colour (the Selected Text colour from my chosen KDE colour scheme)
that doesn't stand out against the background.

The check should be made bolder or otherwise more visible, or should not use the
selected text colour.

This could be due to some config setup on my system, rather than a general
problem, but it seems to be a problem on any themes I use.

I currently have the Keramik theme and KDE Default colour scheme, which results
in very light blue checks on a white background.

See attached image, where the checkbox is checked, but very hard to see at a glance.
Comment 1 Jonathan Wakely 2006-07-22 07:51:16 EDT
Created attachment 132860 [details]
image showing barely visible check
Comment 2 Jonathan Wakely 2006-07-22 07:55:43 EDT
Created attachment 132861 [details]
another example of hard to see checks

Here is another example, this time from the WebDevelopers Toolbar extension
(which uses the same themes) and it is very hard to make out which boxes are
ticked because of the very light blue.
Comment 3 Matěj Cepl 2007-07-18 13:32:05 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 4 Jonathan Wakely 2007-07-18 17:32:03 EDT
reproduced with an up-to-date FC6

$ rpm -q firefox
firefox-1.5.0.12-1.fc6
firefox-1.5.0.12-1.fc6

both screenshots are still valid, I can provide new ones if desired but there's
not a lot of point, the colours are the same

what other info do you need? I don't know if this is a firefox, GTK, KDE or
soemthing else issue.
Comment 5 Jonathan Wakely 2007-07-18 20:16:45 EDT
Created attachment 159569 [details]
gtk widgets

it does seem to be a GTK thing, this is from the gtk-demo application provided
by gtk2-2.10.13-1.fc6 - so not specific to firefox

Running KDE, with Keramic theme. I have no idea what gtk theme.

If I uncheck the "apply colors to non-KDE applications" box in Control Centre,
under Appearances & Themes -> Colours then the gtk widgets are much more
visible, so it seems to be an interaction between Qt and gtk ... ?
Comment 6 Christopher Aillon 2007-08-07 12:27:04 EDT
Probably just using a poor gtk theme.  Sending to gtk to help figure this out,
but my guess is the answer is choose a different theme.
Comment 7 Matthias Clasen 2007-08-10 14:15:56 EDT
Yeah, choose a different theme, please
Comment 8 Jonathan Wakely 2007-08-10 22:57:20 EDT
ok.
I didn't pick this one in the first place, but will change it.

Note You need to log in before you can comment on or make changes to this bug.