Bug 19981 - Install failure
Install failure
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-29 02:45 EST by vidar
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-31 08:25:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vidar 2000-10-29 02:45:23 EST
The install failed several times, always at the same point; right after
formatting /. The traceback is included below.

I was trying to install with partitions "/", "/boot", "/home", "/pub",
"/backup" and "/c". All exept the last one are ext2 filesystems. The last
one is a fat32 fs. Only "/" and "/boot" was formatted, the others were
leftovers from a previous install.

When excluding all but "/" and "/boot" from the install, the error did no
longer occur, which leads me to believe that the FAT32 filesystem caused
the error.

-----------------------------------------------------------------------
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//c

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Need Real Name 2000-10-30 22:34:53 EST
I had the exact same error occur for me.  The only difference is that instead 
of "fsystem: /mnt/sysimage//c", I had "fsystem: /mnt/sysimage//mnt/data"

I had one fat 32 partition ("C:" in windows, I think /dev/hda1) I wanted to put 
as /mnt/win98 
I had another fat 32 partition ("D:" in windows, I think /dev/hda5) I wanted to 
put as /mnt/data

Other than that, my error was the same as this guy's, word for word.
I'm just not gonna tell anaconda about my fat32 partitions, and set it up 
manually later.  No big deal for me, since I know how to do that, but the 
message was a bit scary for me at first.
Comment 2 Daniel Roesen 2000-10-31 08:25:23 EST
Errata update for the installer is available.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.