Bug 1998179 - Build python-QtPy for epel8
Summary: Build python-QtPy for epel8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-QtPy
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1998177 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-26 14:15 UTC by Pablo Greco
Modified: 2021-09-13 04:10 UTC (History)
3 users (show)

Fixed In Version: python-QtPy-1.10.0-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-10 16:18:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Pablo Greco 2021-08-26 14:15:49 UTC
Description of problem:
git-cola was updated to 3.10 and with that, python-QtPy was devendored, making it impossible to install/update

https://src.fedoraproject.org/rpms/git-cola/c/204c98f0aee181aad2149987dba9fd5a9be00a0b?branch=rawhide

How reproducible:
Always


Steps to Reproduce:
1. Try to install/update git-cola


Actual results:
 Problem: cannot install the best update candidate for package git-cola-3.7-1.el8.noarch
  - nothing provides python3dist(qtpy) needed by git-cola-3.10.1-2.el8.noarch


Expected results:
git-cola is installed/updated

Additional info:
mockbuild works

Comment 1 David Aguilar 2021-08-27 22:50:48 UTC
Howdy, please note that the git-cola installation issue affects EPEL7 as well. We're on RHEL7.x and noticed that we are unable to upgrade.


    Error: Package: git-cola-3.10.1-1.el7.noarch (mirror-epel-7)
               Requires: python36-inotify
    Error: Package: git-cola-3.10.1-1.el7.noarch (mirror-epel-7)
               Requires: python36dist(qtpy)


EPEL7 is supposed to be RHEL7 compatible. It seems like it'd need to bring in python36-qt5 as well. I'm upstream's upstream so let me know if there's any information I can provide.

Maybe that version should be pulled from EPEL7?

Comment 2 David Aguilar 2021-08-27 23:24:56 UTC
Somewhat related (git-cola) pull requests that may help as well (they eliminate the inotify dependency):

https://src.fedoraproject.org/rpms/git-cola/pull-request/5

https://src.fedoraproject.org/rpms/git-cola/pull-request/4

That way only qtpy remains as a todo to sort out.

Comment 3 Mukundan Ragavan 2021-08-28 22:48:12 UTC
I have never built qtpy on epel. What version does EPEL need?

Comment 4 David Aguilar 2021-08-29 01:59:37 UTC
For cola, any somewhat modern version would do. 1.9 should be just fine for cola. 1.10 would be fine as well.

Comment 5 Fedora Update System 2021-08-29 10:15:17 UTC
FEDORA-EPEL-2021-4f4474f06f has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-4f4474f06f

Comment 6 Fedora Update System 2021-08-29 10:46:09 UTC
FEDORA-EPEL-2021-57b5a6b654 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-57b5a6b654

Comment 7 Fedora Update System 2021-08-29 18:43:49 UTC
FEDORA-EPEL-2021-4f4474f06f has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-4f4474f06f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-08-29 18:54:05 UTC
FEDORA-EPEL-2021-57b5a6b654 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-57b5a6b654

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Mukundan Ragavan 2021-08-29 21:04:01 UTC
Can you give this scratch build a shot?

https://koji.fedoraproject.org/koji/taskinfo?taskID=74757787


If things work for you, I will build and submit an update.

Comment 10 David Aguilar 2021-08-29 21:22:52 UTC
For EPEL7 I think we'll need one more tweak https://src.fedoraproject.org/rpms/git-cola/pull-request/6

We use the vendored qtpy on EPEL7.

Comment 11 Mukundan Ragavan 2021-09-01 00:07:53 UTC
Can you confirm that the build on comment #9 works for you before I merge?

Comment 12 David Aguilar 2021-09-01 07:17:08 UTC
For Python3.6 on RHEL8 yes, that package looks good to go to me. We should be able to use this in EPEL8's git-cola package. Thanks for getting that together so quickly!

Comment 13 david08741 2021-09-01 14:30:58 UTC
Can you also build qtpy for epel7?

Comment 14 David Aguilar 2021-09-01 19:42:07 UTC
PR #6 in git-cola (for epel7) makes it so that we don't need qtpy on epel7 by continuing to use the vendored version.

If that gets merged then we won't need qtpy for epel7.

I'm not sure which is preferred but that's the basic options (merge PR #6 or provide qtpy). The git-cola spec in epel7 is already setup to use its own vendored qtpy, so the only diff in the PR is dropping the unnecessary "Requires:" line.

Comment 15 Fedora Update System 2021-09-01 22:42:48 UTC
FEDORA-EPEL-2021-8d47a53a5a has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-8d47a53a5a

Comment 16 Mukundan Ragavan 2021-09-01 22:47:36 UTC
*** Bug 1998177 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2021-09-03 00:34:47 UTC
FEDORA-EPEL-2021-8d47a53a5a has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-8d47a53a5a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2021-09-03 00:34:53 UTC
FEDORA-EPEL-2021-8aa5e8ef4a has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-8aa5e8ef4a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2021-09-04 19:58:45 UTC
FEDORA-EPEL-2021-3a6c9cd069 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-3a6c9cd069

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2021-09-10 16:18:27 UTC
FEDORA-EPEL-2021-8d47a53a5a has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2021-09-10 16:18:34 UTC
FEDORA-EPEL-2021-8aa5e8ef4a has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2021-09-13 04:10:56 UTC
FEDORA-EPEL-2021-3a6c9cd069 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.