Bug 199830 - AIGLX: Screen 0 is not DRI capable (after updates) - Broken gdm, xinit
AIGLX: Screen 0 is not DRI capable (after updates) - Broken gdm, xinit
Status: CLOSED DUPLICATE of bug 199809
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-22 20:37 EDT by Bob Agel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 01:26:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Agel 2006-07-22 20:37:57 EDT
Description of problem: After updates, cannot boot into runlevel 5 in gnome,
kde, Xfce.  After boot sequence, it simply hangs on a blue screen and does not
boot into the desktop.

After changing to runlevel 3 and then attempting 'startx', it fails as follows:

AIGLX: Screen 0 is not dri capable
xkb_keycodes {include "xfree86+aliases(querty)"};
xkb_tyupes {include "complete"};
xkb_symbols {include "pc(pc105)+us"}
xkb_geometry {include "pc(pc105)"}
FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing" 

and then it halts and stalls.

I am now in backup FC-5 for the moment until a fix can be achieved.  I'd also
appreciate any details of how to repair FC-6 from runlevel 3, since runlevel 5
will be impossible. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bob Agel 2006-07-23 07:05:53 EDT
Workaround found here:
https://www.redhat.com/archives/fedora-test-list/2006-July/msg00549.html

moved /etc/X11/xinit/xinitrc.d/localuser.sh to /home/bob/borked and again
booting fully.
Comment 2 Lars G 2006-07-23 18:27:08 EDT
after todays update it boots ok now with localuser.sh in place,
but i have this problem now

$ sudo nautilus
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
cannot open display: (null)
Run 'nautilus --help' to see a full list of available command line options.

i think this problem also prevents puplet from being displayed in the panel.
Comment 3 Mike A. Harris 2006-07-24 01:26:54 EDT
This issue was resolved with an xinit update by ajax a few days ago.


Lars:  Please use the mailing list to discuss your issue. If it turns out to
be a bug and is still present in the latest rawhide updates, file a new bug
report against the problematic component.  Thanks in advance.



*** This bug has been marked as a duplicate of 199809 ***

Note You need to log in before you can comment on or make changes to this bug.