Bug 199838 - Missing *.pyc files after yum upgrade
Missing *.pyc files after yum upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-23 01:29 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 08:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2006-07-23 01:29:52 EDT
Description of problem:
After upgrading from an installed package to a newer version of the package,
some .pyc files are missing when querying the rpm database. Previous bugs were
filed for other s-c-* packages. This package still exhibits the problem.
The problem seems to happen because some files that are already owned by the
package are rm *.pyc during the cleanup stage of rpm.

Version-Release number of selected component (if applicable):
system-config-soundcard-2.0.1-1

How reproducible:
Upgrade system via pup or yum

Steps to Reproduce:
1. run yum update
2. rpm -qaV |grep missing >rpm-missing.txt
3. review file for results
  
Actual results:
missing     /usr/share/system-config-soundcard/probeCard.pyc
missing     /usr/share/system-config-soundcard/soundcard.pyc
missing     /usr/share/system-config-soundcard/soundcardBackend.pyc
missing     /usr/share/system-config-soundcard/soundcardBackendHal.pyc
missing     /usr/share/system-config-soundcard/soundcardBackendKudzu.pyc
missing     /usr/share/system-config-soundcard/soundcardBackendProc.pyc
missing     /usr/share/system-config-soundcard/soundcardBackendSoundCard.pyc
missing     /usr/share/system-config-soundcard/system-config-soundcard.pyc


Expected results:
Query to come back with no problems detected.

Additional info:
mozilla and s-c-* rpms seem to be the highest failures.

Note You need to log in before you can comment on or make changes to this bug.