Bug 199858 - rsnapshot: broken FE4->FE5 upgrade path
rsnapshot: broken FE4->FE5 upgrade path
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rsnapshot (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-23 07:37 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: release 4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-23 13:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-07-23 07:37:11 EDT
The version-release of rsnapshot in FE4 is newer than the one in FE5 and devel:

rsnapshot:
  4: 0:1.2.9-4.fc4 (FE4)
  5: 0:1.2.9-2.fc5 (FE5)
  6: 0:1.2.9-2.fc6 (FE6)

Fix: bump FE5 an devel to something >= 4%{?dist} and rebuild.

The FE4 bumps seem tho have been made without a changelog entry.  If you need to
fix something in an old distro branch, append a dot and a digit *after* %{?dist}
so that there's no need to rebuild everything for all newer branches too.
https://www.redhat.com/archives/fedora-extras-list/2006-May/msg00083.html
Comment 1 Chris Petersen 2006-07-23 13:55:08 EDT
Sorry, I got caught in the "make tag" nightmare where it creates the tag but
fails to build because of a not-checked-in file.  The fc4 bump was purely to
compensate for that.  Should be fixed now.
Comment 2 Ville Skyttä 2006-07-23 14:10:51 EDT
Sure, thanks, but in the future, if you need to similar things, the link in the
initial comment contains a recipe for doing it in a non-intrusive way (eg.
2%{?dist}.1 instead of 3%{?dist} in the old distro only).

Note You need to log in before you can comment on or make changes to this bug.