Bug 1998665 - Impossible to install any new addons and enable existing one.
Summary: Impossible to install any new addons and enable existing one.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1998707 1998999 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-27 21:48 UTC by David Hill
Modified: 2021-09-24 20:19 UTC (History)
18 users (show)

Fixed In Version: thunderbird-91.1.0-1.fc34 thunderbird-91.1.0-1.fc33 thunderbird-91.1.0-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-10 16:04:41 UTC
Type: Bug


Attachments (Terms of Use)
Fix for thunderbird 91.03-2 (704 bytes, patch)
2021-09-03 13:41 UTC, Patrick Laimbock
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 1727113 0 None None None 2021-09-01 09:22:13 UTC

Description David Hill 2021-08-27 21:48:44 UTC
Description of problem:
Impossible to install any new addons and enable existing one .   Same as 
https://github.com/NixOS/nixpkgs/issues/134433 and https://www.reddit.com/r/Thunderbird/comments/p5jffe/cannot_install_any_extensions/



How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 David Hill 2021-08-28 16:28:55 UTC
Patch over thunderbird-91.0.3-1.fc36.src.rpm:

--- thunderbird.spec	2021-08-26 04:37:14.000000000 -0400
+++ thunderbird.spec.dave	2021-08-27 18:17:45.636665732 -0400
@@ -318,6 +318,8 @@
 echo "ac_add_options --without-system-nss" >> .mozconfig
 %endif
 
+echo "ac_add_options --with-unsigned-addon-scopes=app,system --allow-addon-sideload" >> .mozconfig
+
 # Second arches fail to start with jemalloc enabled
 %ifnarch %{ix86} x86_64
 echo "ac_add_options --disable-jemalloc" >> .mozconfig
@@ -453,6 +455,7 @@
 MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -Wformat-security -Wformat -Werror=format-security"
 %else
 # Workaround for mozbz#1531309
+export MOZ_REQUIRE_SIGNING=
 MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-Werror=format-security//')
 %endif
 # Use hardened build?

Comment 2 Julian Sikorski 2021-09-01 09:21:23 UTC
*** Bug 1998999 has been marked as a duplicate of this bug. ***

Comment 3 Julian Sikorski 2021-09-01 09:21:28 UTC
*** Bug 1998707 has been marked as a duplicate of this bug. ***

Comment 4 Julian Sikorski 2021-09-02 09:46:08 UTC
It does not seem fixed as of thunderbird-91.0.3-2.fc34.x86_64.

Comment 5 Didier G 2021-09-02 11:32:11 UTC
I just upgraded from thunderbird-91.0.3-1.fc34.x86_64 to thunderbird-91.0.3-2.fc34.x86_64

Problem is NOT fixed in 91.0.3-2

Comment 6 Patrick Laimbock 2021-09-03 13:41:12 UTC
Created attachment 1820281 [details]
Fix for thunderbird 91.03-2

See https://phabricator.services.mozilla.com/D124361

Comment 7 Jan Horak 2021-09-03 13:57:35 UTC
Yes, it's still kind of broken ATM. I'm able to switch the language in fresh profile. I found out that the $profile/extensions.json has the all langpacks userDisabled set to true in old langpack. I'm not sure if that's your case, but it's keeping resetting to the true when extensions.json is deleted.

Comment 8 Patrick Laimbock 2021-09-04 11:29:24 UTC
I built Thunderbird 91.0.3-2 plus the patch from https://phabricator.services.mozilla.com/D124361 and adding an add-on works again (in my case TBsync + EAS). The packages are available here:
https://copr.fedorainfracloud.org/coprs/patrickl/thunderbird/

Comment 9 Markus Teuber 2021-09-04 11:39:38 UTC
(In reply to Patrick Laimbock from comment #8)
> I built Thunderbird 91.0.3-2 plus the patch from
> https://phabricator.services.mozilla.com/D124361 and adding an add-on works
> again (in my case TBsync + EAS). The packages are available here:
> https://copr.fedorainfracloud.org/coprs/patrickl/thunderbird/

Great news. I did an upgrade from 78.12.0 to your built and all works well again. I can switch to german language pack and after a restart, all add-ons and localisation works for me.
Thank you a lot.

Comment 10 Didier G 2021-09-05 14:45:31 UTC
(In reply to Patrick Laimbock from comment #8)
> I built Thunderbird 91.0.3-2 plus the patch from
> https://phabricator.services.mozilla.com/D124361 and adding an add-on works
> again (in my case TBsync + EAS). The packages are available here:
> https://copr.fedorainfracloud.org/coprs/patrickl/thunderbird/

Hi Patrick, you did the job !
I just upgraded from hunderbird-91.0.3-2.fc34.x86_64 from Fedora repo to hunderbird-91.0.3-3.fc34.x86_64 from your copr repo.
I am now able to install french language and enable extensions.
Thanks for your job.

Comment 11 Harald Reindl 2021-09-07 08:51:58 UTC
may i ask what's wrong with you maintainers throw TB91 on Fedora 33 users?
guess why we didn't jump to F34 until now - to get obvious issues fixed before

Comment 12 Patrick Laimbock 2021-09-07 12:44:37 UTC
(In reply to Harald Reindl from comment #11)
> may i ask what's wrong with you maintainers throw TB91 on Fedora 33 users?
> guess why we didn't jump to F34 until now - to get obvious issues fixed
> before

I'm not a maintainer but here is the Fedora policy if you have an issue with this update:
https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#problems-or-issues-with-updates

Comment 13 Didier 2021-09-08 08:38:03 UTC
Patrick's TB 91.0.3 patch compiled for F33 : 
https://copr.fedorainfracloud.org/coprs/ifas/thunderbird/

Comment 14 Fedora Update System 2021-09-09 12:51:46 UTC
FEDORA-2021-7a74c98205 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-7a74c98205

Comment 15 Fedora Update System 2021-09-09 12:51:49 UTC
FEDORA-2021-7e4dfca020 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-7e4dfca020

Comment 16 Fedora Update System 2021-09-09 12:51:50 UTC
FEDORA-2021-9f357482fe has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-9f357482fe

Comment 17 Jan Horak 2021-09-09 12:57:59 UTC
Please test the latest 91.1.0 version. 

Regarding disabled langpacks: it's possible that you have already disabled langpacks because of starting the firefox with wrong 'extensions.autoDisableScopes' preference. It must be set to 0. Otherwise the system langpacks will be disabled in the profile and there's no reverse for that, only deleting extensions.json from your profile. The extensions.json will be regenerated during the next start from extensions in the user profile, so the installed extensions won't be removed.

Please feel free to give me a feedback and I'm sorry for the troubles.

Comment 18 Fedora Update System 2021-09-09 17:39:09 UTC
FEDORA-2021-7e4dfca020 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7e4dfca020`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7e4dfca020

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Didier 2021-09-09 17:52:30 UTC
(In reply to Jan Horak from comment #17)
> Please test the latest 91.1.0 version. 

thunderbird-91.1.0-1.fc33.x86_64 works fine :
- new addons are installed ;
- existing addons are enabled.

(did not test langpacks)

Comment 20 Fedora Update System 2021-09-09 18:15:30 UTC
FEDORA-2021-7a74c98205 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7a74c98205`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7a74c98205

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2021-09-09 21:06:53 UTC
FEDORA-2021-9f357482fe has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-9f357482fe`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-9f357482fe

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2021-09-10 16:04:41 UTC
FEDORA-2021-7e4dfca020 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2021-09-21 15:24:52 UTC
FEDORA-2021-7a74c98205 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 24 Fedora Update System 2021-09-24 20:19:42 UTC
FEDORA-2021-9f357482fe has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.