Bug 199881 - glibc-2.3.4-2.19.src.rpm and glibc-2.3.4-2.22.src.rpm fail to build on sparc64
glibc-2.3.4-2.19.src.rpm and glibc-2.3.4-2.22.src.rpm fail to build on sparc64
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.0
sparc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-23 17:59 EDT by Johnny Hughes
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 05:15:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
adds include socket.h to several glibc .c files (2.20 KB, patch)
2006-07-23 17:59 EDT, Johnny Hughes
no flags Details | Diff

  None (edit)
Description Johnny Hughes 2006-07-23 17:59:27 EDT
Description of problem:
glibc-2.3.4-2.19.src.rpm and glibc-2.3.4-2.22.src.rpm fail to build on sparc64

Version-Release number of selected component (if applicable):
glibc-2.3.4-2.19.src.rpm, glibc-2.3.4-2.22.src.rpm

How reproducible:
Always

The problem is that patch glibc-nscd-EINTR.patch uses "MSG_NOSIGNAL" and "send"
but they are not previously defined.

Using:

#include <sys/socket.h>

in several .c files fixes this problem and allows both glibc SRPMS to build on
sparc64.

The attached patch corrects the problem.
Comment 1 Johnny Hughes 2006-07-23 17:59:27 EDT
Created attachment 132890 [details]
adds include socket.h to several glibc .c files
Comment 2 Jakub Jelinek 2006-08-29 05:15:33 EDT
This is unnecessary.  sys/socket.h is included in all those files, via
<errno.h> including <tls.h>, which includes either LinuxThreads or NPTL
<descr.h>.  <descr.h> includes <resolv.h>, which includes <netinet/in.h>
and that includes <sys/socket.h>.

Note You need to log in before you can comment on or make changes to this bug.