Bug 1998879 - /usr/bin/h5fc-64: line 238: syntax error near unexpected token `)'
Summary: /usr/bin/h5fc-64: line 238: syntax error near unexpected token `)'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hdf5
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-29 17:25 UTC by Ralf Corsepius
Modified: 2021-09-24 20:11 UTC (History)
5 users (show)

Fixed In Version: hdf5-1.10.7-2.fc35
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-24 20:11:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Ralf Corsepius 2021-08-29 17:25:21 UTC
Description of problem:

# /usr/bin/h5fc-64
/usr/bin/h5fc-64: line 238: syntax error near unexpected token `)'
/usr/bin/h5fc-64: line 238: `    *\'*)'


Version-Release number of selected component (if applicable):
hdf5-devel-1.10.7-1.fc35.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Invoke /usr/bin/h5fc-64

Actual results:
See above.

Expected results:
Function.

Additional info:
Apparent cause is a typo (a dangling ") in the snippet below from hdf5-wrappers.patch:

diff -up hdf5-1.10.7/fortran/src/h5fc.in.wrappers hdf5-1.10.7/fortran/src/h5fc.in
--- hdf5-1.10.7/fortran/src/h5fc.in.wrappers    2020-08-27 21:38:23.000000000 -0600
+++ hdf5-1.10.7/fortran/src/h5fc.in     2020-10-07 20:25:53.793962985 -0600
@@ -83,11 +83,11 @@ FLINKERBASE="@FC@"
 # libraries in $link_args, followed by any external library paths and libraries
 # from AM_LDFLAGS, LDFLAGS, AM_LIBS or LIBS carried in from the hdf5 build.
 # The order of the flags is intended to give precedence to the user's flags.
-H5BLD_FCFLAGS="@AM_FCFLAGS@ @FCFLAGS@"
+H5BLD_FCFLAGS=
 F9XMODFLAG="@F9XMODFLAG@"
 F9XSUFFIXFLAG="@F9XSUFFIXFLAG@"
-H5BLD_LDFLAGS="@AM_LDFLAGS@ @LDFLAGS@"
-H5BLD_LIBS="@LIBS@"
+H5BLD_LDFLAGS="
+H5BLD_LIBS=

 FC="${HDF5_FC:-$FCBASE}"
 FLINKER="${HDF5_FLINKER:-$FLINKERBASE}"


The line containing
H5BLD_LDFLAGS="
should be
H5BLD_LDFLAGS=
or may be
H5BLD_LDFLAGS=""

Comment 1 Fedora Update System 2021-08-31 04:05:21 UTC
FEDORA-2021-9a27841b45 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-9a27841b45

Comment 2 Fedora Update System 2021-08-31 17:57:17 UTC
FEDORA-2021-9a27841b45 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-9a27841b45`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-9a27841b45

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2021-09-24 20:11:57 UTC
FEDORA-2021-9a27841b45 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.