Bug 1999148 - ClusterMonitoringOperatorReconciliationErrors is firing during upgrades and should not be
Summary: ClusterMonitoringOperatorReconciliationErrors is firing during upgrades and s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.8.z
Assignee: Philip Gough
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1978829
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-30 14:09 UTC by Philip Gough
Modified: 2021-09-14 06:58 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1978829
Environment:
job=release-openshift-origin-installer-old-rhcos-e2e-aws-4.9=all
Last Closed: 2021-09-14 06:57:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1351 0 None None None 2021-08-30 14:13:28 UTC
Red Hat Product Errata RHBA-2021:3429 0 None None None 2021-09-14 06:58:07 UTC

Comment 3 Junqi Zhao 2021-09-01 05:32:08 UTC
checked with the PR, ClusterMonitoringOperatorReconciliationErrors detail now is
        - alert: ClusterMonitoringOperatorReconciliationErrors
          annotations:
            message: Cluster Monitoring Operator is experiencing unexpected reconciliation
              errors. Inspect the cluster-monitoring-operator log for potential root causes.
          expr: max_over_time(cluster_monitoring_operator_last_reconciliation_successful[5m])
            == 0
          for: 1h
          labels:
            severity: warning

Comment 8 errata-xmlrpc 2021-09-14 06:57:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3429


Note You need to log in before you can comment on or make changes to this bug.