Bug 199920 - Review Request: Palantir
Review Request: Palantir
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Package Reviews List
:
Depends On:
Blocks: FE-DEADREVIEW
  Show dependency treegraph
 
Reported: 2006-07-24 07:18 EDT by Tim Niemueller
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 13:37:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Niemueller 2006-07-24 07:18:34 EDT
Spec URL: http://www.niemueller.de/projects/extrpms/packages/fedora-extras-5/palantir.spec
SRPM URL: http://www.niemueller.de/projects/extrpms/packages/fedora-extras-5/palantir-2.6-1.i386.rpm
Description: A multichannel interactive streaming solution. Allows for streaming webcam audio and video and receiving it with different clients, Java and Qt client are supplied with the package.
Comment 2 Parag AN(पराग) 2006-07-24 23:53:58 EDT
Not able to download SRPM
ERROR 404: Not Found
Comment 3 Tim Niemueller 2006-07-25 04:24:40 EDT
Please try again. It's there now.
Comment 4 Hans de Goede 2006-07-26 11:00:19 EDT
Doesn't build for me as normal user, because it tries to chown installed files:
if [ ! -d /var/tmp/palantir-root/usr/share/palantir ] ; then \
           mkdir -p /var/tmp/palantir-root/usr/share/palantir ; \
           chown root /var/tmp/palantir-root/usr/share/palantir ; \
           fi
chown: changing ownership of `/var/tmp/palantir-root/usr/share/palantir':
Operation not permitted

I guess this can be circumvented for the dir case by first doing an mkdir -p.

Please post a new version with this fixed.
Comment 5 Tim Niemueller 2006-08-07 20:03:13 EDT
New package online at
http://www.niemueller.de/projects/extrpms/packages/fedora-extras-5/palantir-2.6-2.src.rpm
(spec at original URL). All rpmlint warnings have been fixed, scripts have been
updated according to hints given (in the other review requests). The mentioned
problem has been fixed with an extended Makefile patch.
Comment 6 Hans de Goede 2006-08-11 00:52:32 EDT
MUST:
=====
O rpmlint output is:
W: palantir hardcoded-packager-tag Tim
W: palantir redundant-prefix-tag
W: palantir setup-not-quiet
W: palantir mixed-use-of-spaces-and-tabs
These all must be fixed
* Package and spec file named appropriately
* Packaged according to packaging guidelines
* License ok, license file included
* spec file is legible and in Am. English.
* Source matches upstream
* "Compiles" and builds on FC-5 i386
* BR: ok
* No locales
* No shared libraries
* Not relocatable
* Package owns / or requires all dirs
* No duplicate files & Permissions ok
* %clean & macro usage OK
* Contains code only
* %doc does not affect runtime, and isn't large enough to warrent a sub package
* no -devel package needed, no libs / .la files.
* no .desktop file required

MUST fix
========
* rpmlint output:
W: palantir hardcoded-packager-tag Tim
Remove the packager tag
W: palantir redundant-prefix-tag
Remove the prefix tag
W: palantir setup-not-quiet
Add -q to %setup
W: palantir mixed-use-of-spaces-and-tabs
Only uses spaces for indenting, not tabs
* Add: "%defattr(-,root,root,-)" to the subpackages
  %files .
* Source0 must be a full URL

Questions:
==========
* I assume the java client doesn't build with gcj? Have you tried?
* Why is the building of the QT client optional and not done by default, since
  it is in a subpackage the user can always choose to not install it so I would 
  prefer to always build it and atleast build it by default.
Comment 7 Kevin Fenzi 2006-09-02 01:11:11 EDT
Removing FE-NEEDSPONSOR, as submitter was sponsored in: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=175047
Comment 8 Hans de Goede 2006-10-25 03:58:10 EDT
ping?
Comment 9 Hans de Goede 2006-11-19 02:14:36 EST
ping again? If I still get no response within one week I'm closing this as a
dead review.

Note You need to log in before you can comment on or make changes to this bug.