Bug 199931 - invalid bash test in /etc/profile.d/kde.sh
invalid bash test in /etc/profile.d/kde.sh
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
5
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 09:30 EDT by Chris Moller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 09:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Moller 2006-07-24 09:30:04 EDT
Description of problem:


Version-Release number of selected component (if applicable): kdelibs-3.5.3-0.4.fc5

How reproducible:

ssh from one machine into an fc5 machine.

Steps to Reproduce:
      ssh hotbox                         (hotboxis running Fedora Core release 5
(Bordeaux))
  
Actual results:
    An error message:  /etc/profile.d/kde.sh:4: = not found

Expected results:
     No error messages.

Additional info:

Line 4 of  /etc/profile.d/kde.sh is:

     if [ xx"$PRELINKING" == "xxyes" ] ; then

(or something like that; I've changed it.   But the point is that...)
The [....] construct in bash is invalid for comparison tests; it should be [[....]]

      if [[ xx"$PRELINKING" == "xxyes" ]] ; then

(I bugzilla-ed the kde guys about this, but they said it was a Fedora problem...)
Comment 1 Ngo Than 2006-07-24 09:38:37 EDT
yes, it's not upstream bug. The bug has been already fixed in 
kdelibs-3.5.3-0.4.fc5. Your /etc/profile.d/kde.sh has not been upgraded 
because you have changed it and it's marked as noreplace.


Note You need to log in before you can comment on or make changes to this bug.