Bug 199948 - using Livna nVidia kernel modules in rawhide causes incorrect rendering of text
using Livna nVidia kernel modules in rawhide causes incorrect rendering of text
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 11:25 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 11:05:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of me viewing Google.ca with buggy text rendering (96.30 KB, image/png)
2006-07-24 11:31 EDT, Stewart Adam
no flags Details

  None (edit)
Description Stewart Adam 2006-07-24 11:25:12 EDT
Description of problem:
After updating to glib2-2.12.1, text isn't rendered correctly on the screen.
It's not there until I select it or put my mouse over the text in question, and
even still it might dissapear again after. See my screenshot (attachment) for
more info.

Version-Release number of selected component (if applicable):
glib2-2.12.1

How reproducible:
Always

Steps to Reproduce:
1. Update to the new glib2
2. Restart your computer
3. Login again
  
Actual results:
Text is rendered incorrectly

Expected results:
It should be like normal

Additional info:
I'm sorry if there's typos or missing spots, I can't really see what I'm typing
well because it keeps dissapearing - Is there a quick workaround for this? It
basically renders the computer unusable...
Comment 1 Stewart Adam 2006-07-24 11:31:36 EDT
Created attachment 132925 [details]
Screenshot of me viewing Google.ca with buggy text rendering
Comment 2 Matthias Clasen 2006-07-24 12:13:52 EDT
glib is not directly involved in text rendering. How did you arrive at the
conclusion that the glib update is to blame ?
Comment 3 Matthias Clasen 2006-07-24 12:24:42 EDT
This is said to be an X bug with EXA drivers.
Comment 4 Stewart Adam 2006-07-24 12:57:07 EDT
Well, I only updated a few packages - kernel, selinux-policy-targeted, libsilc,
gaim and gaim-guifications. Since SELinux, gaim, gaim-guification and libsilc
have nothing to do with it, it leaves kerenl and glib2. Booting the old kernel
didn't do anything, and so that leaves glib2... Since all GTK+ apps are affected
on my computer, I figured this was it... Anyways, I downgraded to the previous
version, 2.12.0-1, and it's still happening - How can I fix these EXA drivers if
that's it?
Stewart
Comment 5 Stewart Adam 2006-07-24 14:19:00 EDT
Found it - I had custom built my own Livna nVidia modules, and installed them -
But hadn't restarted X. In that same session, I did those updates so I though it
was the updates... In fact, it was the nVidia drivers. I've disabled them and
I'm not using the 'nv' driver in Xorg, and all is fine. I've changed the summary
to reflect the correct problem, which isn't glib2. Sorry for the trouble!
Stewart
Comment 6 Stewart Adam 2006-08-10 10:23:40 EDT
I did more research into this and found that it's because the nVidia modules
don't support Xorg v7.1... Anyways, it requires:
Option "RenderAccel" "0"
in /etc/X11/xorg.conf and now text is rendered correctly, and Ihave 3D
accelleration.
Stewart

Note You need to log in before you can comment on or make changes to this bug.