This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 199961 - ecj can't cope with [] brackets in pathnames
ecj can't cope with [] brackets in pathnames
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
: 162177 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 12:22 EDT by Andrew Haley
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.1-32.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-27 00:33:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
It's a jar (105.63 KB, application/octet-stream)
2006-07-24 12:22 EDT, Andrew Haley
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 161996 None None None Never

  None (edit)
Description Andrew Haley 2006-07-24 12:22:53 EDT
Description of problem:

ecj can't cope with [] brackets in pathnames

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. try to build the attacked srpm

 rpmbuild -bi perseus-cache.spec


2. 
3.
  
Actual results:

    [javac] incorrect classpath:
/homes/home/aph/rpmbuild/BUILD/cache/output/build:/homes/home/aph/rpmbuild/BUILD/cache/externals/[fractal][fractal].jar:/homes/home/aph/rpmbuild/BUILD/cache/externals/[monolog][ow
    [javac]
_monolog].jar:/usr/share/java/ant.jar:/usr/share/java/ant-launcher.jar:/usr/share/java/jaxp_parser_impl.jar:/usr/share/java/xml-commons-apis.jar:/usr/share/java/objectweb-anttask.jar:/usr/lib/jvm/java/lib/tools.jar

Expected results:


Additional info:
Comment 1 Andrew Haley 2006-07-24 12:22:53 EDT
Created attachment 132930 [details]
It's a jar
Comment 2 Ben Konrath 2006-07-25 16:43:47 EDT
I have a patch but I'm having trouble running the test because perseus-cache has
a lot of dependencies that are not in the Fedora repo I'm using. Is there a repo
I can use to get these deps or do you have another test?
Comment 4 Andrew Overholt 2006-08-01 13:32:48 EDT
*** Bug 162177 has been marked as a duplicate of this bug. ***
Comment 9 John Thacker 2006-10-28 16:49:38 EDT
Assume from when this was filed that it's FC6T2, changing version.
Comment 10 Ben Konrath 2006-10-28 18:09:00 EDT
(In reply to comment #9)
> Assume from when this was filed that it's FC6T2, changing version.

Yeah, but the bug is in FC6 too. 
Comment 11 Ben Konrath 2006-12-06 14:18:03 EST
A fix for this issue is in FC6-updates (3.2.1-23.fc6) and rawhide. The patch
needs a bit of work still so I'm keeping this bug open for now.
Comment 12 Ben Konrath 2007-01-27 00:33:27 EST
3.2.1-32.fc7 has the final update to this patch and I'll include the last fix
with next update to FC-6. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.