Bug 200000 - (bug200k) Project->Build Special Targets dialog is empty
Project->Build Special Targets dialog is empty
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 15:59 EDT by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 17:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2006-07-24 15:59:48 EDT
Description of problem:
Project->Build Special Targets dialog is empty

Version-Release number of selected component (if applicable):
eclipse-cdt-3.1.0-1jpp_7fc.i386

How reproducible:
Always

Steps to Reproduce:
1. Create or check-out a "C/C++ Autotools" project
2. Select the project itself in the "C/C++ Projects" view
3. Go to Project -> Build Special Targets
  
Actual results:
Empty dialog.

Expected results:
Targets in dialog.

Additional info:
Comment 1 Anthony Green 2006-07-26 00:25:18 EDT
Congratulations on filing bug #200000 :-)
Comment 2 Andy Shevchenko 2006-07-26 10:55:26 EDT
Congratulations on filing bug #200000

What a gift is author get?

Comment 3 Jeff Johnston 2006-07-31 17:26:09 EDT
The problem is that the Special Targets dialog is created from the Makefile.  If
the project has not yet been built (i.e. configured), the Makefile doesn't yet
exist so there is nothing to parse.  What would be needed would be a dialog to
ask if the user wants to run the configure step.

Please confirm that you do not have any such problem once the project has been
built and that I have diagnosed this correctly.
Comment 4 Jeff Johnston 2006-08-21 17:48:09 EDT
A patch has been applied to create the Makefile via configuring if it does not
already exist.

Note You need to log in before you can comment on or make changes to this bug.