Bug 200016 - IA64 Radeon 7000 and X with Update 2
IA64 Radeon 7000 and X with Update 2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 16:40 EDT by Petros Koutoupis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEL4 U4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 08:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petros Koutoupis 2006-07-24 16:40:06 EDT
Description of problem:

This is regards to Update 2 of RHEL ES4 and X with the IA64 ATI Radeon 7000
graphics card.  The system halts once a graphical mode is loaded unless you
adjust the xorg.conf with the supported resolution and also frequency.  A fix is
given through X's website but does redhat hold a fix for this issue listed below?
-----------------
XFree86 Support for Itanium Systems

   The  XFree86.4.1.0-44  package  available  with  this  release
   provides  a  fix  for  Itanium  (IA64)  systems (related bugs:
   74404,  79855,  and  79909).  Previous  XFree86  packages  for
   Itanium systems removed the int10 module (which provides video
   card  BIOS  support  to  the X Server) from the XFree86 module
   list.

   Hewlett-Packard  IA64/ZX1  systems are not tolerant of some of
   the  bus accesses that occur when the int10 module attempts to
   execute  the  video  BIOS  found  on the card. During X Server
   initialization,  an  HP IA64/ZX1 system will typically machine
   check  (hard  system failure requiring reboot). However, other
   Itanium systems can correctly execute video card BIOS.

   Because  some graphic card drivers require the int10 module to
   be  present and to execute correctly the int10 module has been
   returned  to  the  set  of  modules  in Red Hat Linux Advanced
   Server  2.1 for the Itanium Processor. If at run-time it
   is  determined the host is an HP IA64/ZX1 system, execution of
   int10  is  disabled; otherwise, the int10 module is loaded and
   executed.  For  the  set  of  supported  graphics  cards on HP
   IA64/ZX1  systems  (ATI  Radeon VE) this load failure does not
   create  a problem as the driver selects an alternate method to
   initialize itself.

----------------
OS     Minimum Resolution  Refresh Rate  Maximum Resolution  Refresh Rate
HP-UX     1024x768            75 Hz           1920x1200         75 Hz
Linux     1024x768            75 Hz           1920x1200         75 Hz
Windows    640x480            75 Hz           1600x1200         75 Hz
OpenVMS    640x480            60 Hz           1920x1200         75 Hz
Comment 1 Mike A. Harris 2006-07-25 08:58:24 EDT
The current release of RHEL-4 is update 4.  Please update to the current
release and run up2date to ensure your system is fully updated.

After you have updated, if the problem you were experiencing is still
present, please contact Red Hat support services at http://www.redhat.com/support
to open a support ticket, or by telephone at 1-888-RED-HAT1 depending on your
support contract.


Note You need to log in before you can comment on or make changes to this bug.