Bug 200037 - kernel-2.6.17-1.2396.fc6 crashes with illegal instruction
kernel-2.6.17-1.2396.fc6 crashes with illegal instruction
Status: CLOSED DUPLICATE of bug 200549
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 20:04 EDT by Trever Adams
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-28 12:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error (849.02 KB, image/jpeg)
2006-07-27 19:18 EDT, Trever Adams
no flags Details

  None (edit)
Description Trever Adams 2006-07-24 20:04:01 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install the above i586 rpm.
2. Try to boot
3. Shortly after boot (right after IDE initialization I think) the system will
crash with an illegal instruction
  
Actual results:
Crash with illegal instruction.

Expected results:
A good boot.

Additional info:

Last used kernel on this system was kernel-2.6.17-1.2439.fc6. System is K6-2
late model (350 or 500 Mhz). 128 MB of RAM. No taint at this point in boot
(later on I use a madwifi driver, but this is pre-load).
Comment 1 Trever Adams 2006-07-25 16:34:50 EDT
kernel-2.6.17-1.2445.fc6

I believe it is trying to run a 686 instruction (compexch). I do not know that.
I cannot save a log, but would a digital photo of the screen help?
Comment 2 Dave Jones 2006-07-26 00:18:55 EDT
Sure, can't hurt to get any debug info we can right now, because I'm out of
ideas what's going on.

Note that you can also get more lines of text onscreen using vga=1 if it helps.
Comment 3 Trever Adams 2006-07-27 19:18:51 EDT
Created attachment 133206 [details]
screenshot of error

Ok, this is a bit blurry. I am sorry, I shake. I believe I can read most of it,
so hopefully you get what you need. If not, I will try to get my hands on a
tripod (not easy for me). This is definitely an illegal opcode being executed,
so my guess is there is an assembly routine that uses something it should not
or the compiler flags are broken.
Comment 4 Dave Jones 2006-07-28 12:49:24 EDT
Ah, someone else just hit this bug, and they have a clearer photo, so I'll dupe
this bug against that one :-)


*** This bug has been marked as a duplicate of 200549 ***

Note You need to log in before you can comment on or make changes to this bug.