Bug 2000447 - [rfe] Torrent type download for DNF
Summary: [rfe] Torrent type download for DNF
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-02 07:44 UTC by Thomas Stephen Lee
Modified: 2021-09-06 13:33 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-06 13:33:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Stephen Lee 2021-09-02 07:44:48 UTC
Description of problem:

Unlike RHEL, Fedora and EL8 rebuilds have mirrors.
It would be great if the DNF install/update used multiple mirrors like torrents, speeding up the download process. We do not know how hard this is to implement. We feel that the code might be there somewhere.

Version-Release number of selected component (if applicable):

All

How reproducible:

It is a feature request.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jaroslav Mracek 2021-09-06 13:33:36 UTC
Thank you very much for report. It looks like that we already some level of support of torrent in https://dnf-plugins-extras.readthedocs.io/en/latest/torproxy.html. I know it is not exactly what you requested but at least the field was opened.
 
On other hand we do not have a plan to implement something else related to torrents in near future because we have more important tasks ahead of us. I also think that such a torrent logic should be not implemented in DNF but in library shared by multiple components like curl.

I am really sorry that I don't have better information for you.


Note You need to log in before you can comment on or make changes to this bug.