Bug 200077 - hal + kernel 2.6.18-rc, devices fail to automount
hal + kernel 2.6.18-rc, devices fail to automount
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
Depends On:
  Show dependency treegraph
Reported: 2006-07-25 07:56 EDT by Andrew Clayton
Modified: 2013-03-13 00:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-03 13:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew Clayton 2006-07-25 07:56:48 EDT
Description of problem:

With a FC5 on an i386 with a 2.6.18-rc[12] kernel. Plugging in a USB data stick
when logged into GNOME fails to automount and no icon on the desktop. Works on
2.6.17 and the latest FC kernel.

The interesting thing is this works on FC5 x86-64 with 2.6.18-rc. Also if you
boot the i386 machine with the stick in place, when you are logged into GNOME
there is an icon for it. However unmounting the device and replugging it results
in no automount/icon.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Plug in data stick
Actual results:


Expected results:

Stick should get mounted and an icon placed on the desktop

Additional info:
Comment 1 Vedran Miletić 2006-07-30 08:50:34 EDT
HAL added support for kernels >2.6.17.
If you want, you can install HAL 0.5.8 cvs (that should also work) from utopia
repo - http://people.freedesktop.org/~hughsient/fedora/
Comment 2 Andrew Clayton 2006-07-31 11:46:37 EDT
Got the update to hal- however still no cigar.

The thing is this was working on the x64-64 FC5 before the update (still works
after of course)

If I get a chance I may try the 0.5.8cvs snapshot.
Comment 3 Matthias Clasen 2006-07-31 13:41:58 EDT
Does this problem occur on rawhide too ?
Comment 4 Andrew Clayton 2006-08-01 11:45:09 EDT
Updated the kernel (2.6.18-rc3) on another x86 FC5 machine and it now has the
same problem.

Just tried the utopia repo from above but that didn't help. My x86_64
workstation continues to work fine, 2.6.18-rc2, hal-
Comment 5 Andrew Clayton 2006-08-02 04:56:02 EDT
I'm afraid I don't have any rawhide to test.
Comment 6 Andrew Clayton 2006-08-02 06:10:30 EDT
Dunno if this helps any but I ran udevmonitor on two of the above machines to
compare differences.

Here is the last few line from my x86-64/FC5 workstation, 2.6.18-rc2,
hal- (I seem to have both i386 and x86-64 versions installed)

UEVENT[1154510670.246094] add@/block/sdb
UEVENT[1154510670.246115] add@/block/sdb/sdb1
UEVENT[1154510670.246119] add@/class/scsi_device/12:0:0:0
UDEV  [1154510670.250690] add@/class/scsi_device/12:0:0:0
UDEV  [1154510670.383650] add@/block/sdb
UDEV  [1154510670.555570] add@/block/sdb/sdb1
UEVENT[1154510671.433544] mount@/block/sdb/sdb1
UDEV  [1154510671.434129] mount@/block/sdb/sdb1

This works fine. The device got mounted.

Heres the last few lines from an i386/FC5, 2.6.18-rc2, hal-

UEVENT[1154513402.853689] add@/block/sdb
UEVENT[1154513402.853708] add@/block/sdb/sdb1
UEVENT[1154513402.853716] add@/class/scsi_device/2:0:0:0
UDEV  [1154513402.864618] add@/block/sdb
UDEV  [1154513402.874035] add@/class/scsi_device/2:0:0:0
UDEV  [1154513402.900793] add@/block/sdb/sdb1

No mount lines, and the device was indeed not mounted.
Comment 7 John (J5) Palmieri 2006-08-03 13:01:21 EDT
We don't ship that kernel. Please file upstream with HAL.
Comment 8 Andrew Clayton 2006-08-03 14:06:16 EDT


Note You need to log in before you can comment on or make changes to this bug.