Bug 200104 - libtabe fails to build in mock with minimal build environment.
libtabe fails to build in mock with minimal build environment.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libtabe (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-BuildReq
  Show dependency treegraph
 
Reported: 2006-07-25 10:50 EDT by Paul Howarth
Modified: 2013-01-09 23:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 03:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing build on rawhide (923 bytes, patch)
2006-07-25 10:50 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Paul Howarth 2006-07-25 10:50:06 EDT
This package fails to build in mock if the minimal build group is reduced to
only the packages listed in the Exceptions section of the packaging guidelines.

The issue can be fixed by:

1: Changing the xorg-x11-devel buildreq to libXt-devel
2: Adding a --x-includes= option to %configure that specifies an empty or
non-existent directory (needed to work around a bug in the automake-made
Makefiles, which include an empty -I compiler flag otherwise)

Patch attached.

This should fix the build on FC5 too.

I'd also suggest adding a %{?dist} tag to Release:
Comment 1 Paul Howarth 2006-07-25 10:50:07 EDT
Created attachment 132993 [details]
Patch fixing build on rawhide
Comment 2 Caius Chance 2006-09-05 03:08:33 EDT
Update:

As xcin are not included in fedora, libtabe will be excluded from fedora extras.

FYI, xcin requires libtabe.

Note You need to log in before you can comment on or make changes to this bug.