Bug 2001441 - Test: oc adm must-gather runs successfully for audit logs - fail due to startup log
Summary: Test: oc adm must-gather runs successfully for audit logs - fail due to star...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.9
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.10.0
Assignee: Eran Cohen
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On:
Blocks: 2002543
TreeView+ depends on / blocked
 
Reported: 2021-09-06 06:42 UTC by Eran Cohen
Modified: 2022-03-10 16:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 2002543 (view as bug list)
Environment:
Last Closed: 2022-03-10 16:07:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 26450 0 None None None 2021-09-06 06:44:09 UTC
Red Hat Product Errata RHSA-2022:0056 0 None None None 2022-03-10 16:07:24 UTC

Description Eran Cohen 2021-09-06 06:42:35 UTC
Description of problem:

the SNO CI started to fail due to panic in oc adm must-gather runs successfully for audit logs
Seems that there is a new file in the audit logs .....internal-startup.log.gz that cause the issue.
Seems related to this PR: https://github.com/openshift/cluster-kube-apiserver-operator/pull/1219

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run the test on SNO
2.
3.

Actual results:
Test fail due to panic:
E0905 05:07:13.258759   30266 runtime.go:76] Observed a panic:
Your test failed.
Ginkgo panics to prevent subsequent assertions from running.
Normally Ginkgo rescues this panic so you shouldn't see it.

Expected results:


Additional info:

Comment 3 Xingxing Xia 2021-09-09 12:30:53 UTC
PR is test code only to exclude startup log in audit log checking

Comment 6 errata-xmlrpc 2022-03-10 16:07:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.10.3 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2022:0056


Note You need to log in before you can comment on or make changes to this bug.