Bug 200149 - gnome-panel doesn't exit cleanly when X server dies
gnome-panel doesn't exit cleanly when X server dies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-07-25 14:42 EDT by Ray Strode [halfline]
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 14:07:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 348803 None None None Never

  None (edit)
Description Ray Strode [halfline] 2006-07-25 14:42:36 EDT
gnome-panel gets stuck if the X server is killed from under it.

It seems like SIGPIPE has been set to SIG_IGN and so it doesn't die appropriately. 

The stack trace looks bogus, but it could be there is some atexit handler doing
bad things or something.
Comment 1 Ray Strode [halfline] 2006-07-26 11:21:28 EDT
So alex, kevin, and I looked at this today.  It turns out there is an atexit
handler setup by ORBit to do shutdown.  This results in panel_applet_frame
noticing its connection with the applet died and trying to pop up a dialog
asking if we'd like to reload the applet.  Popping up the dialog results in an X
round trip (because somewhere in the stack we call gdk_x11_get_server_time) and
this makes us spin.
Comment 2 Deji Akingunola 2006-08-14 11:17:58 EDT
This still happens (to me) on FC6-Test2, fully updated to rawhide as of 2006-8-13.
gnome-panel has been crashing a lot lately, and each time it does I have to
Ctrl-Alt-Bkspace to get back at login screen and re-login. But then the gnome
panel wouldn't start claiming another instance is running. I have to drop to
tty1 and kill the defunct gnome-panel there before I could proceed.

Note You need to log in before you can comment on or make changes to this bug.