Bug 20015 - Python2.0 doesn't compile out of the box on RedHat7
Summary: Python2.0 doesn't compile out of the box on RedHat7
Status: CLOSED DUPLICATE of bug 19088
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-30 08:16 UTC by braunm
Modified: 2016-11-24 15:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 08:16:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description braunm 2000-10-30 08:16:55 UTC
Python2.0 doesn't compile out of the box on RedHat7
i.e. using the Python2.0 distribution released about 3 weeks ago 
the compilation bombs out in Include/pyport.h 
this can be circumvented by uncommenting the if endif 
pair immmediately before the line in pyport.h where
the error is reported
this seems to be caused by some changes to limits.h and xopen_limits.h !
The  Python maintainers have been contacted: their reply was 
"We will not make a change in the Python source tree to work around a
broken
Linux distro.  It is straightforward to fix this yourself"

please fix this!!!!
Python is important for you!!

regards

Moritz Braun

UNISA
South Africa

Comment 1 Jakub Jelinek 2000-10-30 08:26:51 UTC

*** This bug has been marked as a duplicate of 19088 ***


Note You need to log in before you can comment on or make changes to this bug.