Bug 20019 - kaiman broken
Summary: kaiman broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdemultimedia   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-30 09:59 UTC by Gerald Teschl
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-20 15:51:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2000-10-30 09:59:07 UTC
kdemultimedia-2.0-1

Starting kaiman takes forever. Choosing a file to play (tested mp3 and au)
and
hitting the play button causes kaiman to freeze.

Comment 1 Bernhard Rosenkraenzer 2000-10-30 10:14:40 UTC
I can't reproduce this on a P3-750 with an SB 128 PCI card or on a P2-450 with a cheapo 16-bit ISA sb card.

Make sure artsd is running and your soundcard is set up correctly.


Comment 2 Gerald Teschl 2000-10-30 10:32:49 UTC
arts is running and the soundcard is set up correctly (I get the kde startup
sound at login).

I have a Yamaha card (opl3sa2).

Comment 3 Gerald Teschl 2000-11-15 16:50:39 UTC
I tried to strace kaiman. First everything looks normal until it comes to the
point

<SNIP>
read(3, "\2\3\0\0024\0\0\0", 8)         = 8
read(3, "O\0\0\0", 4)                   = 4
read(3, "\0\0\0\vDCOPServer\0\0\0\0\20anonymous-203"..., 52) = 52
write(3, "\2\2\2\0]\0\0\0O\0\0\0", 12)  = 12
write(3, "\0\0\0\20anonymous-20316\0\0\0\0\7kaiman\0\0"..., 64) = 64
write(3, "\0\0\0\r/home/gerald\0\0\0\0\1\0\0\0\0\0\0\0\0", 29) = 29
read(3, "\2\5\0\2#\0\0\0", 8)           = 8
read(3, "O\0\0\0", 4)                   = 4
read(3, "\0\0\0\7kaiman\0\0\0\0\20anonymous-20316\0\0"..., 35) = 35
read(3, "\2\6\0\0023\0\0\0", 8)         = 8
read(3, "O\0\0\0", 4)                   = 4
read(3, "\0\0\0\7kaiman\0\0\0\0\20anonymous-20316\0\0"..., 51) = 51        
 
At the last "read(3," the output will suddenly stop. The harddrive will start
heavily
working and kaiman will eat up 20% of CPU (PII 300) and 15% of my memory (96MB).
After about a minute kaiman will put itself into the background and the main
window
pops up.

I can choose a file to play, but as soon as I hit play, the harddrive starts
heavily working
again and artsd uses 10% CPU for about another minute. Then kaiman will display
the file title and artsd will use 5% CPU. However, both kaiman and artsd are
dead
and can only be stopped using "kill -9".

Comment 4 Gerald Teschl 2000-12-10 19:22:37 UTC
kdemultimedia-2.0.1-1

kaiman now starts up normally, but hitting the play button still causes kaiman
and
artsd to crash as before.
(Using xmms + the artsd plugin works fine)

Comment 5 Gerald Teschl 2000-12-20 15:51:04 UTC
works in kdenetwork-2.0.1-3


Note You need to log in before you can comment on or make changes to this bug.