Bug 200202 - broken keyboard mapping
broken keyboard mapping
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sturmbahnfahrer (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 02:45 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 03:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2006-07-26 02:45:13 EDT
Description of problem:
As mention during the package review in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=199310#c10


The "Examine keyboard controls" page says:
'Steer left  less than'
'Steer right greater than'
 
I found "left/right" on "," rsp. "." (German "qwertz" keyboard)

Version-Release number of selected component (if applicable):
sturmbahnfahrer-1.1-2.fc5
Comment 1 Hans de Goede 2006-07-26 03:28:28 EDT
Version 1.1-3, should show up on a mirror near you soon.
This version has the following changes which should fix this:
* Wed Jul 26 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.1-3
- Added a patch to call the left and right keys COMMA and POINT instead of
  LESSTHEN and GREATERTHEN, so that the text is correct for non qwerty
  keyboards too. And add a binding for normal brake to the Y key for more
  convenient controls with a German (QWERTZ) keyboard.
  Upstream has been notified that the current hardcoded keys are awkward
  with non qwerty keyboards so that upstream can create a proper fix.
Comment 2 Ralf Corsepius 2006-07-26 03:34:53 EDT
Hmm, this sounds like an ugly hack to me?

Doesn't the toolkit stormbahnfahrer applies (SDL?) provide proper keyboard
mapping routines?
Comment 3 Hans de Goede 2006-07-26 03:45:14 EDT
sturmbahnfahrer uses plib. And the code actually checks for ',' and '.' so the
new help text is correct. With regards to adding the Y binding that is because
the Y is on QWERTZ where the Z is on QWERTY. The problem is not as much keyboard
mapping which plib does fine AFAIK, the problem is that its best to use keys at
a certain location instead of keys with a certain symbol.

Comment 4 Bram Stolk 2006-07-26 12:52:03 EDT
The next version of sturmbahnfahrer will come with configurable key controls.
I never liked the in-game "change controls" options, so I will opt for a 
config file or something. (env var even?)

Also, I will make sure that in addition to configured keys, the 
cursor keys will work as well.

  Bram

Note You need to log in before you can comment on or make changes to this bug.