Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: Trying to admin my cps server by "firefox localhost:613". The brwoser window is displayed, but if clicking the "Administration" tab lets it hang. Inspecting /var/log/cups/error_log show 3 lines: W [26/Jul/2006:09:11:00 +0200] [cups-deviced] Backend "snmp" did not respond within 30 seconds! W [26/Jul/2006:09:11:18 +0200] [cups-deviced] Backend "snmp" did not respond within 30 seconds! W [26/Jul/2006:09:11:29 +0200] [cups-deviced] Backend "snmp" did not respond within 30 seconds! Version-Release number of selected component (if applicable): cups-1.2.1-1.7 How reproducible: Each time Steps to Reproduce: 1.Start firefox on the cups server: "forefox localhost:631" 2.Click the "Adminstration" tab 3. Actual results: It hangs Expected results: open the admin window or the root authentification prompt Additional info:--
A new CUPS package for FC5 was made available yesterday: https://www.redhat.com/archives/fedora-package-announce/2006-July/msg00097.html Please try that package (just 'yum update') and let me know if the problem is still present. Thanks.
Has already been installed (cups-1.2.2-1.1), but did not help. Tailing /var/log/cups/error_log: I [27/Jul/2006:15:46:12 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=3752) I [27/Jul/2006:15:46:12 +0200] Started "/usr/lib/cups/daemon/cups-deviced" (pid=3753) W [27/Jul/2006:15:46:45 +0200] [cups-deviced] Backend "snmp" did not respond within 30 seconds!
Please show me the full output of: time /usr/lib/cups/backend/snmp Thanks.
It seems that "time /usr/lib/cups/backend/snmp" hangs or is cpu busy: INFO: Using default SNMP Address @LOCAL INFO: Using default SNMP Community public If I stop it after waiting some time by Ctrl+C, then: real 1m0.775s user 0m0.000s sys 0m0.000s It consumed a lot of time. I did a "strace /usr/lib/cups/backend/snmp". The output will be attached.
Created attachment 133214 [details] strace /usr/lib/cups/backend/snmp strace /usr/lib/cups/backend/snmp
Please try this test update: https://www.redhat.com/archives/fedora-test-list/2006-July/msg00666.html You should be able to install this using the command: yum --enablerepo=updates-testing 'cups*' as root. Does the backend still take a long time? If so, please show me the snmp.log from: CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp 2>&1 >snmp.log with the new (1.2.2-1.2) packages installed. Thanks.
Hi, did not help - hangs as before. The output of CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1 has been attached.
Created attachment 133304 [details] CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1
Please try 1.2.2-1.3 from here: http://people.redhat.com/twaugh/tmp/cups-snmp/ It contains a small change that I hope will fix it.
Hi, I'm sorry, but still hangs. Have attached the output of CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp
Created attachment 133395 [details] CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp
Hmm. Please try this: CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log and attach the resulting snmp.log. Thanks.
Created attachment 133460 [details] CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log
Please try 1.2.2-1.4 from here: http://people.redhat.com/twaugh/tmp/cups-snmp/ It contains another small change, and hopefully this really is the fix.
Hi, you fix seems to solve my problem, but not completely: The printer adminstration does no more hang - now, I can modify printers by the "Modify printer" button. But: trying to modify the printer options by "Set printer options" fails with the message "Error: Not Found " I cannot imagine what this message means!
I think we've finally found the fix to the original problem them (great!). I've filed a report about this upstream: http://cups.org/str.php?L1880 Please file a separate bugzilla report about the "set printer options" problem, as it needs to be tracked separately. Thanks.