This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 200205 - snmp backend times out
snmp backend times out
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-07-26 03:04 EDT by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.2.2-1.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 12:08:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace /usr/lib/cups/backend/snmp (3.15 KB, application/postscript)
2006-07-28 00:36 EDT, Joachim Backes
no flags Details
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1 (1.22 KB, application/postscript)
2006-07-31 01:01 EDT, Joachim Backes
no flags Details
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp (1.33 KB, application/postscript)
2006-08-01 09:10 EDT, Joachim Backes
no flags Details
CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log (3.90 KB, application/postscript)
2006-08-02 00:51 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2006-07-26 03:04:18 EDT
Description of problem:
Trying to admin my cps server by "firefox localhost:613". The brwoser window is
displayed, but if clicking the "Administration" tab lets it hang. Inspecting
/var/log/cups/error_log show 3 lines:

W [26/Jul/2006:09:11:00 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!
W [26/Jul/2006:09:11:18 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!
W [26/Jul/2006:09:11:29 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!


Version-Release number of selected component (if applicable):
cups-1.2.1-1.7

How reproducible:
Each time

Steps to Reproduce:
1.Start firefox on the cups server: "forefox localhost:631"
2.Click the "Adminstration" tab
3.
  
Actual results:
It hangs

Expected results:
open the admin window or the root authentification prompt

Additional info:--
Comment 1 Tim Waugh 2006-07-27 09:22:14 EDT
A new CUPS package for FC5 was made available yesterday:

https://www.redhat.com/archives/fedora-package-announce/2006-July/msg00097.html

Please try that package (just 'yum update') and let me know if the problem is
still present.

Thanks.
Comment 2 Joachim Backes 2006-07-27 09:37:06 EDT
Has already been installed (cups-1.2.2-1.1), but did not help.
Tailing /var/log/cups/error_log:

I [27/Jul/2006:15:46:12 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=3752)
I [27/Jul/2006:15:46:12 +0200] Started "/usr/lib/cups/daemon/cups-deviced"
(pid=3753)
W [27/Jul/2006:15:46:45 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!
Comment 3 Tim Waugh 2006-07-27 11:59:07 EDT
Please show me the full output of: time /usr/lib/cups/backend/snmp

Thanks.

Comment 4 Joachim Backes 2006-07-28 00:34:08 EDT
It seems that "time /usr/lib/cups/backend/snmp" hangs or is cpu busy:

INFO: Using default SNMP Address @LOCAL
INFO: Using default SNMP Community public

If I stop it after waiting some time by Ctrl+C, then:

real    1m0.775s
user    0m0.000s
sys     0m0.000s

It consumed a lot of time.

I did a "strace /usr/lib/cups/backend/snmp". The output will be attached.
Comment 5 Joachim Backes 2006-07-28 00:36:17 EDT
Created attachment 133214 [details]
strace /usr/lib/cups/backend/snmp

strace /usr/lib/cups/backend/snmp
Comment 6 Tim Waugh 2006-07-28 11:46:43 EDT
Please try this test update:

https://www.redhat.com/archives/fedora-test-list/2006-July/msg00666.html

You should be able to install this using the command:

  yum --enablerepo=updates-testing 'cups*'

as root.  Does the backend still take a long time?  If so, please show me the
snmp.log from:

  CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp 2>&1 >snmp.log

with the new (1.2.2-1.2) packages installed.  Thanks.
Comment 7 Joachim Backes 2006-07-31 00:58:59 EDT
Hi,

did not help - hangs as before.

The output of CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1 has
been attached.
Comment 8 Joachim Backes 2006-07-31 01:01:04 EDT
Created attachment 133304 [details]
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1
Comment 9 Tim Waugh 2006-08-01 09:02:42 EDT
Please try 1.2.2-1.3 from here:

  http://people.redhat.com/twaugh/tmp/cups-snmp/

It contains a small change that I hope will fix it.
Comment 10 Joachim Backes 2006-08-01 09:09:51 EDT
Hi,

I'm sorry, but still hangs. Have attached the output of
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp
Comment 11 Joachim Backes 2006-08-01 09:10:46 EDT
Created attachment 133395 [details]
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp
Comment 12 Tim Waugh 2006-08-01 09:54:02 EDT
Hmm.  Please try this:

CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log

and attach the resulting snmp.log.  Thanks.
Comment 13 Joachim Backes 2006-08-02 00:51:34 EDT
Created attachment 133460 [details]
CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log
Comment 14 Tim Waugh 2006-08-02 12:22:02 EDT
Please try 1.2.2-1.4 from here:

  http://people.redhat.com/twaugh/tmp/cups-snmp/

It contains another small change, and hopefully this really is the fix.
Comment 15 Joachim Backes 2006-08-03 00:44:39 EDT
Hi,

you fix seems to solve my problem, but not completely:

The printer adminstration does no more hang - now, I can modify printers by the
"Modify printer" button.

But: trying to modify the printer options by "Set printer options" fails with
the message "Error:

    Not Found

"

I cannot imagine what this message means!
Comment 16 Tim Waugh 2006-08-03 05:10:52 EDT
I think we've finally found the fix to the original problem them (great!).  I've
filed a report about this upstream:

  http://cups.org/str.php?L1880

Please file a separate bugzilla report about the "set printer options" problem,
as it needs to be tracked separately.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.