Bug 2002178 - Deploying ovirt HCI fail due to glusterfs-selinux package missing
Summary: Deploying ovirt HCI fail due to glusterfs-selinux package missing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-distribution
Classification: oVirt
Component: glusterfs
Version: 4.4.8
Hardware: x86_64
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.4.9
: 4.4.9
Assignee: Niels de Vos
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-08 07:41 UTC by Vlad Vetu
Modified: 2021-10-13 07:17 UTC (History)
13 users (show)

Fixed In Version: glusterfs-8.6-2.el8 glusterfs-8.6-2.el8s
Doc Type: No Doc Update
Doc Text:
A missing dependency on glusterfs-selinux caused failures running glusterfs-server. The dependency has been added now, so updating glusterfs-server will install the missing package solving the issue.
Clone Of:
Environment:
Last Closed: 2021-10-12 12:49:06 UTC
oVirt Team: Gluster
pm-rhel: ovirt-4.4+
michal.skrivanek: blocker-
sbonazzo: devel_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github gluster glusterfs issues 2780 0 None open RPM packaging for glusterfs-server for CentOS Storage SIG has a missing dependency on glusterfs-selinux 2021-10-11 08:28:42 UTC
Github gluster glusterfs pull 2781 0 None Merged Add missing dependency on glusterfs-selinux 2021-10-05 12:14:02 UTC
Red Hat Issue Tracker RHV-43402 0 None None None 2021-09-08 07:42:47 UTC

Description Vlad Vetu 2021-09-08 07:41:03 UTC
Description of problem:
When trying to deploy a new HyperConverged Infrastructure cluster the installer will fail at labeling gluster bricks.

Version-Release number of selected component (if applicable):
oVirt Node 4.4.8

How reproducible:
Deploy a new ovirt HCI cluster

Steps to Reproduce:
1. install ovirt node OS
2. Run hyperconverged installer through ovirt cockpit-dashboard
3. Leave default selinux configuration for gluster setup

Actual results:
Task failed:
shell: semanage fcontext -a -t glusterd_brick_t "{{ item }}"
ValueError: Type glusterd_brick_t is invalid, must be a file or device type

Expected results:
Installer to complete successfully.

Additional info:
The problem seems to be caused by a missing package on the host glusterfs-selinux
The same error is produced by trying to manually label the bricks.

As a workaround:
For the ovirt-4.4-centos-gluster8 repo add in includepkgs the missing package glusterfs-selinux and manually install it.
Re-run the installer.

[ovirt-4.4-centos-gluster8]
name = CentOS-$releasever - Gluster 8
mirrorlist = http://mirrorlist.centos.org?arch=$basearch&release=$releasever&repo=storage-gluster-8
gpgcheck = 1
enabled = 1
gpgkey = https://www.centos.org/keys/RPM-GPG-KEY-CentOS-SIG-Storage
includepkgs = ovirt-node-ng-image-update ovirt-node-ng-image ovirt-engine-appliance vdsm-hook-fcoe vdsm-hook-vhostmd vdsm-hook-openstacknet vdsm-hook-ethtool-options glusterfs-selinux

Comment 1 RHEL Program Management 2021-09-08 07:44:24 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 2 RHEL Program Management 2021-09-13 09:48:40 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Sandro Bonazzola 2021-09-13 10:11:06 UTC
The problem is that glusterfs-server is missing a dependency on glusterfs-selinux.
Reported to Gluster community here: https://github.com/gluster/glusterfs/issues/2780 .

A new build of oVirt Node will be issued as soon as Gluster team will provide the fix.
In the meanwhile, the workaround suggested in the bug description can be used.

Comment 4 Sandro Bonazzola 2021-09-13 10:25:20 UTC
Pushed a fix to the glusterfs specfile: https://github.com/gluster/glusterfs/pull/2781

Comment 5 Niels de Vos 2021-10-12 11:27:11 UTC
https://lists.gluster.org/pipermail/packaging/2021-October/000975.html

glusterfs-8.6-2.el8 and glusterfs-8.6-2.el8s are available in the
testing repositories. This addresses a dependency issue that recently
was reported in relation to oVirt and SELinux:

- https://bugzilla.redhat.com/2002178
- https://github.com/gluster/glusterfs/issues/2780

Updating should now pull in the glusterfs-selinux package too, assuming
glusterfs-server-8.6.1 or older is installed.

    # dnf --enablerepo=centos-gluster8-test update glusterfs-server

Please report back if this addresses the problem, or if any other
changes are required.

Comment 6 Sandro Bonazzola 2021-10-12 11:52:30 UTC
Thanks Niels, this works for me, waiting for it to be promoted to release


Note You need to log in before you can comment on or make changes to this bug.