This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 200228 - missing ppc packages for compat-gcc-32
missing ppc packages for compat-gcc-32
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compat-gcc-32 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 08:45 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 06:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-07-26 08:45:48 EDT
Description of problem:

Binaries missing for ppc (in devel)??

They seem to be lacking since
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.2.3-55.fc5.1
- rebuild

Version-Release number of selected component (if applicable):



How reproducible:

I don't have a ppc, but I have a dependency for some packages in 
fedora extras (cernlib, patchy, paw), that are built with g77
and therefore depends on libf2c and the missing deps are
automatically found. I wanted to have a closer look at what
was wrong with compat-32-libf2c but it seems to have disappeared
from the ppc rpm download server, I cannot found them on 
http://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc/os/Fedora/RPMS/


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-08-03 09:28:32 EDT
There were no ExcludeArch's added, so it sounds just that the buildsystem messed
it up.  I rebuilt it today, but not sure when it hits rawhide.

In any case, you should consider using gfortran to compile even Fortran 77 stuff,
it should these days subsume all the g77 features.
Comment 2 Patrice Dumas 2006-08-04 07:47:56 EDT
I have considered using gfortran since a long time (and submitted
some bugs there when it broke...), but there are still g77 
regressions and missing intrinsics, for example the cernlib 
still needs g77 for rshift and lshift.

I guess you allready know that regressions are listed there:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=19292

As long as all the bugs listed there and the intrinsics are not
fixed, gfortran cannot be used for all the fortran 77.

Note You need to log in before you can comment on or make changes to this bug.