Bug 2002430 - BFD sessions are not reformed after compute node reboot [NEEDINFO]
Summary: BFD sessions are not reformed after compute node reboot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux Fast Datapath
Classification: Red Hat
Component: openvswitch2.13
Version: FDP 21.J
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Paolo Valerio
QA Contact: Jean-Tsung Hsiao
URL:
Whiteboard:
Depends On:
Blocks: 2012242 2004150 2064016
TreeView+ depends on / blocked
 
Reported: 2021-09-08 19:42 UTC by nalmond
Modified: 2022-03-14 21:26 UTC (History)
21 users (show)

Fixed In Version: openvswitch2.13-2.13.0-142.el8fdp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2004150 2064016 (view as bug list)
Environment:
Last Closed: 2022-02-24 17:47:58 UTC
Target Upstream Version:
kfida: needinfo? (mmichels)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker FD-1534 0 None None None 2021-09-13 18:59:32 UTC
Red Hat Product Errata RHBA-2022:0675 0 None None None 2022-02-24 17:48:09 UTC

Description nalmond 2021-09-08 19:42:28 UTC
Description of problem:
When a compute node is rebooted, the BFD sessions from other nodes to this one do not re-form automatically. After restarting ovs on the other compute nodes the session is re-formed.

Version-Release number of selected component (if applicable):
RHOSP 16.1.6
openvswitch2.13-2.13.0-120.el8fdp.x86_64

How reproducible:
Consistently across a few different environments with similar config/hardware.

Steps to Reproduce:
1. Deploy RHOSP 16.1.6 with ovn
2. reboot a compute node
3.

Actual results:
BFD session does not reform until ovs is restarted on the other nodes

Expected results:
BFD session is reformed without having to restart ovs on the other nodes

Additional info:

Comment 28 Karrar Fida 2021-12-07 13:13:26 UTC
@mmichels@redhat.com can we please target the fix for the first FDP release of 2022. Date is TBD at the moment but the build should be due latest first week of Jan.

Comment 30 Karrar Fida 2022-01-06 10:48:10 UTC
@fleitner@redhat.com can we get this into FDP 22.A?

Comment 31 Flavio Leitner 2022-01-13 16:11:14 UTC
(In reply to Karrar Fida from comment #30)
> @fleitner@redhat.com can we get this into FDP 22.A?

Build including the patch is done, so we should be all set for 22.A release unless QE finds a regression, of course.
fbl

Comment 43 Jean-Tsung Hsiao 2022-02-08 20:13:51 UTC
We have reproduced the issue using openvswitch2.13-2.13.0-120.el8fdp; And, verified the fix using openvswitch2.13-2.13.0-143.el8fdp.
Please review logs below for either case.
Thanks!
Jean

Using openvswitch2.13-2.13.0-120.el8fdp.x86_64:

*** Before host B changed br-dummy MAC addr ***
root@netqe7 bug]# ovs-appctl tnl/neigh/show
IP                                            MAC                 Bridge
==========================================================================
172.168.1.2                                   de:76:88:8d:7b:4e   br-phy

*** After host B changed br-dummy MAC addr ***
[root@netqe7 bug]# ovs-appctl tnl/neigh/show
IP                                            MAC                 Bridge
==========================================================================
172.168.1.2                                   de:76:88:8d:7b:4e   br-phy
[root@netqe7 bug]# 

Using openvswitch2.13-2.13.0-143.el8fdp:

[root@netqe7 bug]# ovs-appctl tnl/neigh/show
IP                                            MAC                 Bridge
==========================================================================
172.168.1.2                                   86:3a:e3:c6:1d:6c   br-phy

*** After host B changed br-dummy MAC addr ***

[root@netqe7 bug]# ovs-appctl tnl/neigh/show
IP                                            MAC                 Bridge
==========================================================================
172.168.1.2                                   86:3a:e3:c6:de:ad   br-phy

Comment 45 errata-xmlrpc 2022-02-24 17:47:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (openvswitch2.13 update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0675


Note You need to log in before you can comment on or make changes to this bug.