Bug 2002668 - workstation profile is not applied correctly when installing workstation from netinst
Summary: workstation profile is not applied correctly when installing workstation from...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2001885 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-09 13:18 UTC by Kamil Páral
Modified: 2021-09-21 20:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-20 15:31:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2021-09-09 13:18:38 UTC
Description of problem:
If I install F35 from Workstation Live, the grubenv then contains "menu_auto_hide" option as specified by workstation profile:
https://github.com/rhinstaller/anaconda/blob/master/data/profile.d/fedora-workstation.conf

$ sudo grub2-editenv - list
saved_entry=3119b9bfac624156b3b5c4d395cbb2b4-5.11.0-155.fc35.x86_64
menu_auto_hide=1
boot_success=1
boot_indeterminate=0

However, if I install F35 from netinst and select "Fedora Workstation" environment in Software selection, grubenv doesn't contain "menu_auto_hide":

$ sudo grub2-editenv - list
saved_entry=3119b9bfac624156b3b5c4d395cbb2b4-5.11.0-155.fc35.x86_64
boot_success=1
boot_indeterminate=0

I.e. the workstation profile wasn't applied correctly in this case.

It is desirable to have the system configured in the same way, regardless of the installation. Otherwise some people complain that their system behaves differently and it's hard to figure out the cause.

Can you please make sure to apply the workstation profile even when installing from netinst (the workstation package set)?


Version-Release number of selected component (if applicable):
tested with:
Fedora-Workstation-Live-x86_64-35-20210904.n.0.iso
Fedora-Everything-netinst-x86_64-35-20210908.n.0.iso

How reproducible:
always

Steps to Reproduce:
1. install a system from Workstation Live, see menu_auto_hide is present in "sudo grub2-editenv - list"
2. install a system from netinst (pick Workstation environment in Software selection), see menu_auto_hide is NOT present in "sudo grub2-editenv - list"

Comment 1 Vendula Poncova 2021-09-20 15:31:02 UTC
Hi, Anaconda profiles are not chosen based on the software selection, but based on the installation environment. The profiles change the default configuration and we need to be able to finalize it before we run anything else. It should be documented here: https://anaconda-installer.readthedocs.io/en/latest/configuration-files.html

The solution you suggest would require a completely different approach. However, I'm afraid it would only cause more confusion. If users choose the Server environment, do the automated partitioning, switch to the Workstation environment and start the installation, they will end up with a mix of configurations for Server and Workstation. That seems worse than the current situation.

The profile can be changed with the inst.profile boot option. The easiest fix could be to extend the boot menu of the installation image and add new items for the profiles you want to support. That wouldn't require any changes in Anaconda and avoid issues mentioned above.

Comment 2 Kamil Páral 2021-09-21 10:12:11 UTC
I just learned about inst.profile. I can confirm that with "inst.profile=fedora-workstation", the netinst boots branded as Fedora Workstation, and the disk layout and grub2 configuration (menu_auto_hide=1) is applied correctly.

I was hoping that at least some of those options (like grub configuration) can be applied based on what software selection the user picked. I understand that for e.g. default disk layout that might be more difficult. But if it is overall technically hard to do, that's unfortunate. The boot menu selection is a good idea, though, thank you.

Comment 3 Robbie Harwood 2021-09-21 20:25:10 UTC
*** Bug 2001885 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.