Bug 200267 - pvm RPM packaging bug crashes up2date
Summary: pvm RPM packaging bug crashes up2date
Status: CLOSED DUPLICATE of bug 191841
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: pvm (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
urgent
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-26 16:39 UTC by Brian Rudy
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 16:44:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Rudy 2006-07-26 16:39:06 UTC
Description of problem:

RPM of latest RHN errata version of pvm fails to install with the following error:

error: unpacking of archive failed on file /usr/share/pvm3/bin/LINUXI386: cpio:
rename failed - Is a directory

This crashes up2date and may leave other components scheduled to be installed in
the up2date session partially installed. During the reporters up2date session,
this left sshd, autofs, crond and nfslock init scripts unregistered. This caused
these services to not start up when the system was rebooted.



Version-Release number of selected component (if applicable):

pvm-3.4.5-6_EL3.i386

How reproducible:

Every time

Steps to Reproduce:
1. rpm -Uvh pvm-3.4.5-6_EL3.i386.rpm

Or

1. up2date
2. select packages to be upgraded, including pvm
3. begin up2date download/installation
  
Actual results:

[root@somebox root]# rpm -Uvh pvm-3.4.5-6_EL3.i386.rpm
Preparing...                ########################################### [100%]
   1:pvm                    ########################################### [100%]
error: unpacking of archive failed on file /usr/share/pvm3/bin/LINUXI386: cpio:
rename failed - Is a directory

[root@somebox root]# rpm --verify pvm
package pvm is not installed


During up2date session, the downloads complete, but when the pvm package is
being upgraded, up2date crashes. All packages marked for installation are shown
as have being installed when up2date is run again, but rpm --verify shows this
is not the case.

Expected results:

Sucessful completion of package update.


Additional info:

Comment 1 Jason Vas Dias 2006-07-26 16:44:40 UTC
This bug is now fixed with the latest pvm-3.4.5-10.EL3 RPMs now being pushed by
RHN for RHEL-3-U8 .


*** This bug has been marked as a duplicate of 191841 ***


Note You need to log in before you can comment on or make changes to this bug.