Bug 2002905 - cluster admin unable to view BuildConfigs in all namespaces
Summary: cluster admin unable to view BuildConfigs in all namespaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.9.0
Assignee: Jon Jackson
QA Contact: Xiyun Zhao
URL:
Whiteboard:
Depends On: 2001810
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-10 02:24 UTC by OpenShift BugZilla Robot
Modified: 2021-11-10 21:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-10 21:01:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10043 0 None None None 2021-09-10 02:24:13 UTC
Red Hat Product Errata RHBA-2021:4119 0 None None None 2021-11-10 21:02:11 UTC

Description OpenShift BugZilla Robot 2021-09-10 02:24:02 UTC
+++ This bug was initially created as a clone of Bug #2001810 +++

Description of problem:
when user tries to view BuildConfigs in all namespaces console is always telling user to select a project or create a Project  

Version-Release number of selected component (if applicable):
4.9.0-0.nightly-2021-09-06-055314

How reproducible:
Always

Steps to Reproduce:
1. in Administrator or Developer perspective, cluster admin user tries to view BuildConfigs in all namespaces through Builds -> BuildConfigs, or just visit URL /k8s/all-namespaces/build.openshift.io~v1~BuildConfig or /k8s/all-namespaces/buildconfigs

Actual results:
a message will be shown on the page 
"Select a Project to view the list of BuildConfigs or create a Project' together with projects list

Expected results:
when user requests to view BuildConfigs in all namespaces, we should return correct BuildConfigs list   

Additional info:

Comment 3 Xiyun Zhao 2021-11-02 01:30:20 UTC
This bug has been fixed and verified on payload 4.9.0-0.nightly-2021-10-30-120753

Verify step:
1. Login in OCP as cluster-admin, using Administrator or Developer perspective, 
2. Navigate to Builds -> BuildConfigs page, and check 'All projects' BC. Or just visit URL /k8s/all-namespaces/build.openshift.io~v1~BuildConfig or /k8s/all-namespaces/buildconfigs
3. Verify if correct BuildConfigs list is returned when user requests to view BuildConfigs in all namespaces

Result:
3. Page will return correct BuildConfig information for all namespaces

Comment 6 errata-xmlrpc 2021-11-10 21:01:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4119


Note You need to log in before you can comment on or make changes to this bug.