Bug 200313 - gcc-4.1.1-12 - segfault from /usr/bin/gcj-dbtool
Summary: gcc-4.1.1-12 - segfault from /usr/bin/gcj-dbtool
Status: CLOSED DUPLICATE of bug 200635
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-26 19:56 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.1.1-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 06:43:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2006-07-26 19:56:30 UTC
Description of problem:

# gdb --args /usr/bin/gcj-dbtool <apparently whatever>
....
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496220496 (LWP 12548)]
0x0000003167903909 in _dl_addr () from /lib64/libc.so.6
(gdb) bt
#0  0x0000003167903909 in _dl_addr () from /lib64/libc.so.6
#1  0x00000034021234fb in _Jv_RegisterLibForGc () from /usr/lib64/libgcj.so.7rh
#2  0x00000034021183ac in _Jv_RegisterClasses () from /usr/lib64/libgcj.so.7rh
#3  0x000000000040271e in _init ()
#4  0x0000000000000003 in ?? ()
#5  0x0000000000404a20 in ?? ()
#6  0x0000003167820a3e in __libc_start_main () from /lib64/libc.so.6
#7  0x0000000000402b49 in ?? ()
#8  0x00007fffa3494cd8 in ?? ()
#9  0x0000000000000000 in ?? ()

This program is used by by /usr/bin/rebuild-gcj-db which, in turn,
shows up in various %post scripts and those clearly fail.

I do not know if the problem is truly limited to x86_64.

Version-Release number of selected component (if applicable):
gcc-4.1.1-12
libgcj-4.1.1-12

How reproducible:
always

Comment 1 Michal Jaegermann 2006-08-01 19:41:04 UTC
The problem re-appeared after the latest round of updates which did NOT
touch gcc or libgcj.  I guess that changes in glibc will be the most
likely trigger here.

A backtrace from gdb with libgcj-4.1.1-13 looks exactly like the above;
only addresses are slightly different.

Comment 2 Jakub Jelinek 2006-08-03 06:43:47 UTC

*** This bug has been marked as a duplicate of 200635 ***


Note You need to log in before you can comment on or make changes to this bug.