Bug 200329 - pyspi fails to work with recent at-spi packages
pyspi fails to work with recent at-spi packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: at-spi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 17:09 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 16:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-07-26 17:09:30 EDT
Description of problem:
Python 2.4.3 (#1, Apr 12 2006, 12:51:08)
[GCC 4.1.0 20060410 (Red Hat 4.1.0-7)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import atspi
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
ImportError: /usr/lib/libspi.so.0: undefined symbol: atk_value_get_minimum_increment

objdump /usr/lib/libspi.so.0 -t

/usr/lib/libspi.so.0:     file format elf32-i386

SYMBOL TABLE:
no symbols


Version-Release number of selected component (if applicable):
at-spi-1.7.9-2
pyspi-0.5.4-3.fc6
Comment 1 Dave Malcolm 2006-07-27 13:28:12 EDT
OK, looks like the recent at-spi needs a recent atk, but this isn't expressed in
the RPM metadata.

I was using:  
atk-1.11.4-4
which didn't provide the necessary symbol.

Updating to atk-1.12.1-2 fixed it.  This isn't expressed in the RPM metadata;
should the so-number of libatk have been bumped?
Comment 2 Matthias Clasen 2006-07-27 14:36:31 EDT
looks like a pyspi problem to me; at-spi source does not contain 
"atk_value_get_minimum_increment"
Comment 3 Dave Malcolm 2006-07-27 16:16:42 EDT
It's not a pyspi problem, it's a dep/version issue of at-spi on atk: a symbol
was added to atk without bumping the so-number.  Hence if you had the newer
at-spi that used the symbol without upgrading atk, at-spi would be unusable.

Fixed by using the most recent version of everything in rawhide, so probably
closable as RAWHIDE
Comment 4 Matthias Clasen 2006-07-27 16:20:44 EDT
No, as I said, at-spi in rawhide is not using that symbol. Anyway, closed.

Note You need to log in before you can comment on or make changes to this bug.