Bug 2003403 - Changing Gnome system sounds volume doesn't work with WirePlumber
Summary: Changing Gnome system sounds volume doesn't work with WirePlumber
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireplumber
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact:
URL:
Whiteboard:
: 2001905 2009519 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-11 21:46 UTC by priv.luk
Modified: 2021-10-16 20:38 UTC (History)
9 users (show)

Fixed In Version: wireplumber-0.4.3-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-08 18:27:42 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
freedesktop.org Gitlab pipewire wireplumber issues 51 0 None closed Changing Gnome system sounds volume doesn't work 2021-10-08 08:13:36 UTC

Description priv.luk 2021-09-11 21:46:59 UTC
Description of problem:
Changing Gnome system sounds volume doesn't work with WirePlumber


Version-Release number of selected component (if applicable): 0.4.1-2.fc35


How reproducible:
Always reproducible on current F35 Workstation Live ISO ( https://kojipkgs.fedoraproject.org/compose/branched/Fedora-35-20210911.n.0/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-35-20210911.n.0.iso )

Steps to Reproduce:
1. Open Settings -> Sound
2. Try to reduce "System Sounds" volume
3. Reopen Settings -> Sound

Actual results:
Volume is still at 100%

Expected results:
Volume is at expected level

Additional info:
Journalctl shows 'Sep 11 10:08:46 localhost-live pipewire-pulse[1736]: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.223811 ], "channels": [ "MONO" ] }'.

Comment 1 Peter Hutterer 2021-09-15 05:03:41 UTC
Confirmed here, same happening here after a F34->F35 upgrade

Comment 2 Juerg Ritter 2021-09-20 21:16:20 UTC
Noticed the same behavior after a fresh F35 installation. It doesn't seem to be possible to mute the Gnome system sounds.

Comment 3 Peter Hutterer 2021-09-21 08:42:26 UTC
Upstream issue: https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/51

Comment 4 Peter Hutterer 2021-09-22 22:22:24 UTC
As an update: this is a missing/incompatible feature in wireplumber but requires some upstream work so it's unlikely it'll be fixed until 0.4.3 (or whatever the next version number will be). Meanwhile, it's best to use pipewire-media-session to work around this bug: "dnf swap wireplumber pipewire-media-session" should do the trick.

Comment 5 Peter Hutterer 2021-09-22 22:24:08 UTC
*** Bug 2001905 has been marked as a duplicate of this bug. ***

Comment 6 Bill 2021-09-24 01:23:10 UTC
Ditto. Same problem here after upgrade from F34>f35.

Comment 7 Leslie Satenstein 2021-09-27 18:09:49 UTC
keywords   System   and  System volume

Re this bug

Please have "system volume" slider act independenty of "system" level  setting.

I may want to block out music, or other text from a video, but I want to have the system volume active to hear error alerts.

Two independent sliders would do good.

Or

[x] link "system volume" setting to system level
(if they were decoupled to act independently

Comment 8 Otto Urpelainen 2021-10-08 08:13:21 UTC
The upstream issue has been resolved.
Wireplumber compiled from upstream master branch does not suffer from this issue any more.
We are just waiting for a new release.

Comment 9 Fedora Update System 2021-10-08 11:43:20 UTC
FEDORA-2021-b70755fdc3 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b70755fdc3

Comment 10 Fedora Update System 2021-10-08 18:27:42 UTC
FEDORA-2021-b70755fdc3 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Felix Kaechele 2021-10-09 21:27:25 UTC
*** Bug 2009519 has been marked as a duplicate of this bug. ***

Comment 12 Leslie Satenstein 2021-10-16 20:38:42 UTC
Fix works for me.


Note You need to log in before you can comment on or make changes to this bug.