Bug 200346 - installs two boot entries for the same kernel
Summary: installs two boot entries for the same kernel
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-07-27 01:10 UTC by Bill Nottingham
Modified: 2014-03-17 03:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 20:19:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log (43.74 KB, text/plain)
2006-07-27 17:05 UTC, Bill Nottingham
no flags Details
anaconda.log (188.54 KB, text/plain)
2006-07-27 17:06 UTC, Bill Nottingham
no flags Details
anaconda.xlog (46.56 KB, text/plain)
2006-07-27 17:07 UTC, Bill Nottingham
no flags Details
anaconda.syslog (56.66 KB, text/plain)
2006-07-27 17:07 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2006-07-27 01:10:25 UTC
Installing on a Thinkpad T40p today, I get:

Fedora Core (2.6.17-1.2449.fc6)
Fedora Core-up (2.6.17-1.2449.fc6)

in grub.

rawhide-20060726

Comment 1 Jeremy Katz 2006-07-27 16:47:44 UTC
That's ... odd.  Can you attach /root/anaconda.log and /var/log/anaconda*

Comment 2 Bill Nottingham 2006-07-27 17:05:27 UTC
Created attachment 133172 [details]
install.log

Comment 3 Bill Nottingham 2006-07-27 17:06:26 UTC
Created attachment 133173 [details]
anaconda.log

Comment 4 Bill Nottingham 2006-07-27 17:07:06 UTC
Created attachment 133174 [details]
anaconda.xlog

Comment 5 Bill Nottingham 2006-07-27 17:07:45 UTC
Created attachment 133176 [details]
anaconda.syslog

Comment 6 Bill Nottingham 2006-07-27 17:18:05 UTC
Looking at anaconda.log, it appeared to add the kernel twice to the transaction
set - perhaps because I had kernel in %packages?


Comment 7 Jeremy Katz 2006-07-27 17:30:55 UTC
Maybe.  Although I can't see why that would do it either :/

Comment 8 Bill Nottingham 2006-07-27 22:00:03 UTC
Confirmed on a second box - UP box + kernel in %packages == two entries.

Comment 9 Jeremy Katz 2006-07-27 22:04:48 UTC
That seems like the obvious reproducer.  Throwing on the blocker list so we
don't lose it.

Comment 10 Jeremy Katz 2006-07-31 20:19:33 UTC
Present in FC5 too... fixed in yum CVS and will be in yum 2.9.4


Note You need to log in before you can comment on or make changes to this bug.