Bug 2003540 - Repeating event: MissingVersion no image found for operand pod
Summary: Repeating event: MissingVersion no image found for operand pod
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.9
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.9.z
Assignee: Antonio Ojea
QA Contact: Rahul Gangwar
URL:
Whiteboard:
: 2003538 (view as bug list)
Depends On: 2001856
Blocks: 2003538
TreeView+ depends on / blocked
 
Reported: 2021-09-13 08:03 UTC by OpenShift BugZilla Robot
Modified: 2021-11-02 23:39 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-26 17:22:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 663 0 None Merged Bug 2003540: bump library-go 2021-11-02 23:37:38 UTC
Github openshift cluster-kube-apiserver-operator pull 1232 0 None Merged Bug 2003540: bump library-go 2021-10-14 02:01:28 UTC
Github openshift cluster-kube-controller-manager-operator pull 564 0 None Merged Bug 2003540: bump library-go 2021-10-14 02:01:28 UTC
Github openshift cluster-kube-scheduler-operator pull 370 0 None Merged Bug 2003540: bump library-go 2021-10-14 02:01:29 UTC
Github openshift library-go pull 1206 0 None Merged [release-4.9] Bug 2003540: Avoid spurious MissingVersion events on the static pod controller 2021-10-14 02:01:31 UTC
Red Hat Product Errata RHBA-2021:3935 0 None None None 2021-10-26 17:22:57 UTC

Comment 3 Antonio Ojea 2021-09-17 13:07:51 UTC
*** Bug 2003538 has been marked as a duplicate of this bug. ***

Comment 4 Rahul Gangwar 2021-09-20 08:04:51 UTC
@Antonio Ojea: As discussed bug only fixed in 4.10 not in 4.9. So I am moving bug back to ASSIGN.

For 4.10:
https://search.ci.openshift.org/?search=no+image+found+for+operand+pod&maxAge=48h&context=1&type=junit&name=4%5C.10&excludeName=upgrade&maxMatches=5&maxBytes=20971520&groupBy=job

Results:
No results found.

For 4.9:
https://search.ci.openshift.org/?search=no+image+found+for+operand+pod&maxAge=48h&context=1&type=junit&name=&excludeName=upgrade&maxMatches=5&maxBytes=20971520&groupBy=job

Results:
#1439826985923645440	junit	24 minutes ago	
event happened 46 times, something is wrong: ns/openshift-kube-apiserver-operator deployment/kube-apiserver-operator - reason/MissingVersion no image found for operand pod
#1439464583604473856	junit	24 hours ago	
event happened 39 times, something is wrong: ns/openshift-kube-apiserver-operator deployment/kube-apiserver-operator - reason/MissingVersion no image found for operand pod

Comment 10 Xingxing Xia 2021-10-15 03:32:50 UTC
Will verify later

Comment 11 Xingxing Xia 2021-10-18 03:43:05 UTC
Reading code https://github.com/openshift/library-go/pull/1203, understood why it was so fixed; It applied to all static pod operators (kas, kcm, ks, etcd), not only kas; the original noisy event creation (https://github.com/openshift/library-go/pull/1049) didn't exclude the false podsFound situation.

In CI, searched 'no image found for operand pod' restricted in 4.9 jobs of recent days, no occurrence is seen for any among kas/kcm/ks/etcd.

Comment 14 errata-xmlrpc 2021-10-26 17:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935

Comment 15 W. Trevor King 2021-11-02 23:39:24 UTC
https://github.com/openshift/cluster-etcd-operator/pull/663 landed after 4.9.0 and shipped in 4.9.4, as described in comment 14.  Updating the Target Release to 4.9.z to match.


Note You need to log in before you can comment on or make changes to this bug.