Bug 20036 - PostgreSQL 7.0.2.17 fails to launch: IPCSemaphoreCreate failed
PostgreSQL 7.0.2.17 fails to launch: IPCSemaphoreCreate failed
Status: CLOSED DUPLICATE of bug 19199
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
alpha Linux
high Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-30 08:46 EST by Sherry Seskevich
Modified: 2016-11-24 10:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 13:12:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sherry Seskevich 2000-10-30 08:46:11 EST
RedHat 7.0 release 2.2.17-3 for Alpha.

Cannot successfully launch PostgreSQL 7.0.2.17 which is bundled with 
RedHat 7.0.  PostgreSQL installs and configures fine.  

To reproduce:  

1. During a Custom RedHat 7.0 installation, select SQL Server (postgresql-
7.0.2-17.alpha.rpm, postgresql-server-7.0.2.17 and postgresql-devel-7.0.2-
17 will be installed by default). 
2. su - postgres
3. initdb --pgdata=/var/lib/pgsql --pglib=/usr/lib/pgsql
4. /usr/bin/postmaster -D /var/lib/pgsql
"This type of error is usually caused by an improper shared memory or 
System V IPC Semaphore configuration.  001027.17.44.02.466 [186823 FATAL 
1: InitProcGlobal: IPCSemaphoreCreate failed." (The application fails to 
open).

Note:  I received the same error when I downloaded, installed and 
configured the postgresql-7.0 source on the RedHat 7.0 system.  I can 
launch postgresql 7.0 when I download, install, configure the same source 
on RedHat 6.2 for Alpha.
Comment 1 Trond Eivind Glomsrxd 2000-10-30 10:30:28 EST
This looks like a duplicate of bug 19199, which we fixed. What glibc do you
have?
Comment 2 Sherry Seskevich 2000-10-30 13:12:06 EST
I am using glibc-2.1.94-3 and glibc-devel-2.1.94-3

Regards,

Sherry

Comment 3 Trond Eivind Glomsrxd 2000-10-30 13:53:52 EST
7.0 for Alpha shipped with glibc 2.1.95-2, which works. You're running som
earlier RC, and not the final realease. I'm marking this as a duplicate of bug
#19199.

*** This bug has been marked as a duplicate of 19199 ***
Comment 4 Sherry Seskevich 2000-10-31 08:45:05 EST
I tested this with the release version (2.2.17-4) of RedHat 7.0 for Alpha and 
was able to successfully launch PostgreSQL.  This problem can be closed.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.