Bug 200364 - createrepo caching is broken for older rpms
Summary: createrepo caching is broken for older rpms
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: createrepo   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-27 06:14 UTC by Ralf Corsepius
Modified: 2014-01-21 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 12:10:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2006-07-27 06:14:28 UTC
Description of problem:
createrepo's caching is non-functional for older rpms, such as rh7.3 built rpms:

It creates cache files names like this:
xxx-[]

Version-Release number of selected component (if applicable):
createrepo-0.4.4-0.1

How reproducible:
Always.

Steps to Reproduce:
1. createrepo -c $(pwd)/cache $(pwd)/RPMS/<rh7.3-rpms>
2. ls ./cache/*

AFAIS, the cause is createrepo's cache file names being based on
%{name}-%{SHA1SUM}. This fails with packages having been built with rpms not
supporting SHA1SUMs.

Comment 1 Seth Vidal 2006-07-27 12:10:50 UTC
This is known and has been fixed in upstream cvs.
thanks

Comment 2 Ralf Corsepius 2006-07-29 05:21:19 UTC
(In reply to comment #1)
> This is known and has been fixed in upstream cvs.

Am I right we can expect an updated rpm any time soon?

I'd really appreciate it, if maintainers would learn to destinguish PRs on bugs
in FC packages from upstream bugs and refrain from closing PRs, which still are
present for the package a PR had been against.


Note You need to log in before you can comment on or make changes to this bug.