Bug 2003723 - [abrt] virt-manager: recalc_geometry(): python3.9 killed by SIGFPE
Summary: [abrt] virt-manager: recalc_geometry(): python3.9 killed by SIGFPE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spice-gtk
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marc-Andre Lureau
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:fb58b12b78331f94a5f9762b389...
: 2006781 2011541 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-13 14:16 UTC by Santiago Gala
Modified: 2021-10-16 20:43 UTC (History)
10 users (show)

Fixed In Version: spice-gtk-0.39-3.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-16 20:43:44 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (216.85 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: core_backtrace (35.32 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: cpuinfo (2.39 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: dso_list (429 bytes, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: environ (1.58 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: limits (1.29 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: maps (3.98 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: mountinfo (3.39 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: open_fds (3.28 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details
File: proc_pid_status (1.40 KB, text/plain)
2021-09-13 14:16 UTC, Santiago Gala
no flags Details

Description Santiago Gala 2021-09-13 14:16:36 UTC
Version-Release number of selected component:
virt-manager-3.2.0-3.fc34

Additional info:
reporter:       libreport-2.15.2
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-virt\x2dmanager-145836.scope
cmdline:        /usr/bin/python3 /usr/bin/virt-manager
crash_function: recalc_geometry
executable:     /usr/bin/python3.9
journald_cursor: s=5db2e05f83e14ccabd6e678dc9d5624b;i=2f3b0;b=cb99f1da142046bb99ea1a97e2a4385f;m=1af557f3dd;t=5cbde8fe7b98a;x=f556147204df2938
kernel:         5.13.14-200.fc34.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 recalc_geometry at ../src/spice-widget.c:1381
 #1 update_size_request at ../src/spice-widget.c:226
 #2 update_area at ../src/spice-widget.c:2722
 #3 spice_display_widget_update_monitor_area at ../src/spice-widget.c:347
 #4 g_cclosure_user_marshal_VOID__INT_INT_INT_INT_INT_POINTER at src/spice-marshal.c:288
 #8 emit_main_context at ../src/gio-coroutine.c:197
 #12 g_main_context_iterate.constprop.0 at ../glib/gmain.c:4131
 #13 g_main_context_iteration at ../glib/gmain.c:4196
 #14 g_application_run at ../gio/gapplication.c:2560
 #15 ffi_call_unix64 at ../src/x86/unix64.S:76

Comment 1 Santiago Gala 2021-09-13 14:16:40 UTC
Created attachment 1822790 [details]
File: backtrace

Comment 2 Santiago Gala 2021-09-13 14:16:42 UTC
Created attachment 1822791 [details]
File: core_backtrace

Comment 3 Santiago Gala 2021-09-13 14:16:43 UTC
Created attachment 1822792 [details]
File: cpuinfo

Comment 4 Santiago Gala 2021-09-13 14:16:44 UTC
Created attachment 1822793 [details]
File: dso_list

Comment 5 Santiago Gala 2021-09-13 14:16:45 UTC
Created attachment 1822794 [details]
File: environ

Comment 6 Santiago Gala 2021-09-13 14:16:47 UTC
Created attachment 1822795 [details]
File: limits

Comment 7 Santiago Gala 2021-09-13 14:16:48 UTC
Created attachment 1822796 [details]
File: maps

Comment 8 Santiago Gala 2021-09-13 14:16:50 UTC
Created attachment 1822797 [details]
File: mountinfo

Comment 9 Santiago Gala 2021-09-13 14:16:51 UTC
Created attachment 1822798 [details]
File: open_fds

Comment 10 Santiago Gala 2021-09-13 14:16:52 UTC
Created attachment 1822799 [details]
File: proc_pid_status

Comment 11 Cole Robinson 2021-09-30 16:58:12 UTC
*** Bug 2006781 has been marked as a duplicate of this bug. ***

Comment 12 Cole Robinson 2021-10-07 18:28:16 UTC
*** Bug 2011541 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2021-10-08 04:29:34 UTC
FEDORA-2021-d4295df52f has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d4295df52f

Comment 14 Victor Toso 2021-10-08 04:30:36 UTC
This was fixed by Marc-André in Bug 1941627, I just backported to F34

Comment 15 Cole Robinson 2021-10-08 13:00:24 UTC
Thanks Victor!

Comment 16 Fedora Update System 2021-10-09 00:59:42 UTC
FEDORA-2021-d4295df52f has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d4295df52f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d4295df52f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2021-10-16 20:43:44 UTC
FEDORA-2021-d4295df52f has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.