Bug 200376 - glibc detected /sbin/loader corrupted double-linked list
glibc detected /sbin/loader corrupted double-linked list
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 06:02 EDT by Info S&R Solutions
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 10:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Info S&R Solutions 2006-07-27 06:02:50 EDT
Description of problem:
When trying to do an update of an old FC system to FC6 rc1 with askmethod and
FTP. The system reports a glibc error.

Version-Release number of selected component (if applicable):
FC6 RC1 disk 1

How reproducible:
Boot with options linux askmethod and select FTP

Steps to Reproduce:
1. Boot with option linux askmethod
2. Select method FTP
3. Select correct nic
4. Enter network settings, static ip used in this case.

  
Actual results:
Typing of the screen
*** glibc detected *** /sbin/loader: corupted double-linked list: 0x08289b18


Expected results:
A nice download and a updated system.


Additional info:
Comment 1 Ulrich Drepper 2006-07-30 14:15:20 EDT
The message clearly states that glibc *detected* the problem.  It not a problem
*in* glibc.  it's the loader which has problem.  I assume it's anaconda.
Comment 2 David Cantrell 2006-07-31 09:57:51 EDT
Yes, it is the loader.  Please try again with rawhide.  We went through a lot of
these problems in FC6 test 1 and it's likely the one you are seeing has been
fixed in rawhide.
Comment 3 David Cantrell 2006-08-03 10:46:12 EDT
Have not heard anything from the reporter and since this is *most likely* one of
the network bugs we fixed post-FC6test1, I'm closing it.
Comment 4 Info S&R Solutions 2006-08-04 06:59:26 EDT
Due to holidays not tested before yesterday but using the development version of
2 augustus solved the ftp install problem. In the console where a lot of selinux
access denied messages. Didn't have time to look into that more closely. But I
think that is was te reason for the terrible slow install.

Note You need to log in before you can comment on or make changes to this bug.