Bug 200380 - Duplicate smbfs mounts also duplicates memory usage per daemon.
Duplicate smbfs mounts also duplicates memory usage per daemon.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 07:07 EDT by Jose Plans
Modified: 2014-08-31 19:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 15:40:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
avoid duplicate smbfs mount point. (2.38 KB, patch)
2006-07-27 07:13 EDT, Jose Plans
no flags Details | Diff
samba-3.0.9-smbmnt_duplicates.patch (2.34 KB, patch)
2006-08-05 13:07 EDT, Jose Plans
no flags Details | Diff

  None (edit)
Description Jose Plans 2006-07-27 07:07:11 EDT
Description of problem:

  Even if that is the wrong thing to do. Mounting N times the same share on the
same mount point produces N allocations of N smbmount daemons.
 
   % mount -t smbfs //host/share /mnt/smbfs
   % mount -t smbfs //host/share /mnt/smbfs
   % mount -t smbfs //host/share /mnt/smbfs
   % mount -t smbfs //host/share /mnt/smbfs

  This will show up as 4 processes with about the equal amount of memory allocated. 

Version-Release number of selected component (if applicable):
samba-client-3.0.9-1.3E.9

How reproducible:
Always.

Steps to Reproduce:
1. mount -t smbfs several times from same share to same mount point.
  
Actual results:
several deamons are used for a single ones task.

Expected results:
Only one daemon as CIFS (kernel thread in this case) performing the operation.

Additional info:
I'm not sure if that is by design tho, but at least it shouldn't allocate memory
for each smbmnt operation.
Comment 2 Jose Plans 2006-07-27 07:13:00 EDT
Created attachment 133141 [details]
avoid duplicate smbfs mount point.
Comment 3 Jose Plans 2006-08-05 13:07:32 EDT
Created attachment 133694 [details]
samba-3.0.9-smbmnt_duplicates.patch
Comment 6 RHEL Product and Program Management 2006-12-19 15:40:56 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.